cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Zephyrus wont turn on?

IronDonkey556
Level 7
Hi all,
I've got a zephyrus GX531GS that I'm having issues with, I bought this laptop used and not working but I'm exhausting my options and not sure where to look.. The previous owner was told the mobo was bad or had a bad capacitor, I looked it over and found that the DC power jack was broken inside, I sent the mobo out for repair at a shop and it the power jack was replaced, the shop tested the mobo and said that it looked good, power was flowing through the whole board.. I got it back and put it back together, plugged it in and still no response to power button or charger...

I went ahead and tested the charger for voltage, it looks good at 19.8v from the wall to the plug
I also replaced the battery and the CMOS battery as well, as the old CMOS was showing 0.6v and the big battery was showing like 0.2v across the pins.

but even with a new CMOS, and a new battery pack, as well as the new DC power jack, I'm still not getting any power /charging light when I plug into the charger.. Nothing turns on when I hit the button.. Not sure where to go from here. I'm wondering if the shop somehow missed a short in the Mobo possibly, but that's my best guess.

Any ideas are appreciated!

Nik
1,020 Views
0 REPLIES 0