Showing results for 
Search instead for 
Did you mean: 

ASUS Zephyrus Duo 16 2023 4090 Black screen and HDR issues with nvidia drivers

Level 10

Now whenever I plug in the power to the laptop, or try booting the laptop with power plugged in, I just have a black screen. The keyboard is still lit up, caps lock light doesn't come on, and I still see the bios image when booting up. I assume that the system is having an issue switching to and/or using the dGPU, but uses the iGPU with no issues. 

This has happed after I moved to the latest 531 NVidia driver.  it is linked to the driver and some issue with the iGPU and dGPU setup as when I return to the original driver that is on the website and the laptop shipped with, the issues is gone. 

Another workaround is to choose standard GPU mode in Armory crate and then in NVidia CP choose NVidia GPU only.  Then the new driver works without crashing however HDR becomes unavailable and when forcing it on it crashes.


This is absurd as I'm stuck between using HDR (main purpose of buying this laptop with the Mini LED) or updating my drivers.


ASUS kindly start addressing concerns with your flagship  products.


Level 10

FYI this is the third laptop I have bought with the Laptop 4090 that is having this issue.  The first two were the strix scar 16s.  

Level 9

On the HDR issue - I recall this was fixed on the previous Zephyrus models with a BIOS update - not sure if this was carried over to the new (2023) models?

It's my understanding that Asus only get chips from Nvidia - they build their own customised solutions for their laptops. What this means is that the generic Nvidia drivers are usually suboptimal.  The Asus drivers available on their support site do work very well and are generally stable - however I have found that the drivers are often a number of versions behind the Nvidia generic ones - which leads to some games not being fully supported in terms of features.

Not sure why Asus is lacking so much in the driver space, it is really not doing their reputation any good 😞

The issue for me though is that the customer at the end of the day is then having to pick up the slack by looking for workaround options in order to get the best out of their machines - which cost them a lot of money.

I hope Asus is monitoring these forums - there are a number of unhappy customers out there.

i agree

Level 10

Issue is still not resolved.  Thousands are having this issue across your 4090 laptops AMD CPY and Intel CPU.  Why are you guys in denial and not even acknowledging it and at least assuring your enthusiast level customers that a potential resolution is underway?

Weirdly, I don't have this problem for some reason. I have HDR both on plugged in and battery and with latest Nvidia drivers. I use the laptop normally with no issues ( SCAR 16 4090). It is probably the recent 309 BIOS update that fixed it for me.

If what you say is true, then you are the one lucky soul that has been able to eclipse this omnipresent issue plaguing their entire range of 4090 laptops. Everyone else on this forum has this issue. Can you share a video of this working? It would be greatly appreciated. 

Here you go:

I hope this is what you are looking for, if not, please let me know.


thanks for sharing. Appreciate your promptness. However this doesn’t show the issue. What me and all others here are facing is something else. Can you please try:

1. Switching HDR on and OFF a few times. 
2. pulling out the power adapter while on desktop and then putting it back.  And can you show these acts via perhaps a phone. So we can see power being pulled out etc. 


if it works for you then perhaps it’s something that can be replicated and help others here as well. Unfortunately all here are facing this issue after having tried everything under the sun. 

Here you go. BTW I enabled HDR on battery by changing battery options to "optimize for battery life", then it allowed to switch HDR on battery, then I returned it to "optimize for image quality", and it didn't turn off HDR.

May I exactly know the issue you are facing?