Showing results for 
Search instead for 
Did you mean: 

Asus rog Zephyrus s17 gx703hs most disappointed purchase of my life

Level 7
Hi everyone,
i decided to create this topic just to know if i am the unlucky guy who took the wrong machine with bugs or everyone share the same pain/feels of me with this machine. My first thought after 8 years of previous laptop (always Asus one of the best tank) was to buy the High S tier of laptop for once so to test the best machine in commerce wih 0 problems and able to do literally anything, from gaming to work always with best performance without thinking, well this machine gave the exactly oppositve, from Nvidia advance optimus bug, from ridicolous performance in QHD (at start i could only play in HD to keep FPS more then 20+), from ridicolous temperature generate even with the new keyboard that lifts from the components to allow more air to enter and SHOULD help (CPU 96° with throttling) and it shutdown twice from the hot in less then one year.

I have to admit the design is incredible but in fact doesn't work, i finally found something work after one year to make this machine less ridocolous with virtually all promises broken, put Intel Turbo boost from "aggressive" to "enable" changed everything, from GPU performance to CPU temperature (i tried disable but it get worst perfomance but better temperature). Consider how much i paid this laptop (4000 euro) i am really disappointed that i have to test and suffer on my skin to find the best settings and they are not in default, like Turbo in armoury crate is a joke compared to Manual and all others stuff

I discovered now that GPU is not running at 140w but at 40-80w maximum during 3d processing, i don't know everytime i found something is never a good thing.

I wanted to share this feel with you, i paid a lot with a lot of sacrifice and Asus should respect people who trust them and give them a lot. I still love this machine, i am genuily think is all about wrong settings here and there but the potential is incredible but i start to be tired to "find" always a solution when the solution should be there at start.

Sorry for my english, for long post and everything.


Community Admin
Community Admin
Hi There, if you are running a Core i9-11900H with an RTX 3080 then you are probably right - something is llikely wrong with your settings. However, you have not provided any details about what games you are trying to run and what kind of performance is expected, Cyberpunk 2077 for example is extremely intensive and so expecting 120+ fps minimum with Ray Tracing enabled on a laptop is slightly unrealistic. Ambient temperature and sufficient airflow is also critical for a laptop of this calibre, please take note. It's normal for high-end GPUs to hit temperatures like that, especially paired with an i9 processor and not under ideal conditions (warm climate + no air-conditioning or fans).

Welcome to the ROG Forum, you can find much info and get the help needed here. Please make your first posts in our forum are about seeking solutions, before declaring a faulty product without confirmation. Thank you.
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin

Hi there, i am glad someone answered. I am sorry about negative attitude but this i how i feel after one year.
I didn't post until there because i was searching solutions, even in my mind a new laptop of this power shoudn't have problems, i was looking at forum too but it didn't work on chrome (ask login without save the session) and even now i am using microsoft edge to just post on it because everything has strange font and not tarnslate in english

I tried multiple games, this is my feedback:
Resident evil village: max settings but only in HD if i changed in QHD framrate drop to unplayable state 15-20fps without ray tracing
Same Resident evil 2 remake: HD good not excellent at QHD same problems of Village
Cyberpunk2077: the only game that worked well at QHD without ray tracing, compare to others DLSS from Nvidia helped a lot
Diablo 2 Resurrected: the game didn't allow you to change resolution so i changed display resolution so i was forced to stay on desktop in 1920x1080 with a QHD monitor, huge disappointmend in this one
Lost Ark: the more problematic, even in HD the PC get super hot and caused shutdown 2 times, the performance are not even good in HD (this convinced me that 96° on components wasn't "normal")
Mortal Kombat 11: even in HD cutscene during cutscenes framte rate drop to 30fps, normal fight game was fine at HD it was around 60fps (the game has cap at 60 FPS for competitive reason)
Elden Ring: a missle in HD drop framerate is huge at QHD

By the way the feel was this PC wasn't able to cap any game, not even close to reviews that was showing QHD or 4k with DSR and 60 fps, even the Nvdia game experience panel suggest me more settings, way more high in "optimize" tab.
I had the luck/opportunity to try 2 of Asus Zephyrus s17 gx703hs, same model 2 different laptop, i discovered they had same problem, so i convinced myself the PC wasn't bug or the problematic one but all model share same problems and the problem could be on some settings there.
I tried to disable Nvidia Advacend Optimus with GPU only and the situation was far better but not even enough to play anygame at QHD and the temperatures were still too high.

This was my situation, totally not happy, with this setup Nvidia 3080 and Tiger Lake processor i was forced to play with less resolution and with drop framerate even in this state. After a while i discovered a "fix", the Intel Turbo boost from power settings save me, this option is not visible in normal settings, you need to enable it in registry or in the console of windows and i found it was on "aggressive" (i don't get why laptop has aggressive option on default when actually is bad and doesn't help laptop at all). I think is not just this some drivers or kind fix from Nvidia helped too (it passed 1 year) and ofc armoury crate setted on manual completely change the performance of the Zephyrus, look like the CPU took all the power and GPU not had enough to show it muscles, turbo mode is not a real turbo mode comprare to manual.

Now i can finally play games at QHD with 30-45fps, but i have the feel everything can change in any moment with any update from windows or components, MSI afterbuner or Nvidia Game expierience show that my GPU power is around on 40-80W when it should be at 125w with a boost to 140w with Dynamic boost. My question is i need to find another hide settings somewhere on web to make this laptop work as it should work from the start or it is normal have this power watts when it could reach more? I am little tired to find solutions to let work this PC at normal state.

I typed a lot in english sorry for all the error is not my primary language,

Anyone get the same problem of mine with the same model of laptop?
How can i increase the watts of GPU from 60w to 140w?

Thank you

I have another problem when i have the option "only GPU" the 3d model get ghostling (black border when you move), this happen in elden ring, lost ark and most of the game, i fixed with set window mode without border instead of full screen. Another problem to add at the list, i really wish it was less complicated to just play at games

Edit: if someone has a better solution for ghostling let me know, thank you

Bump, am i the only one with the Zephyrus s17 gx703hs? Can someone share some usefull info or share performance results? Just to know what is wrong on my settings, i have the QHD version with windows 11. Maybe the 4k version works better

Thank you

Community Admin
Community Admin
The performance you're getting in those game don't make sense, perhaps you are using the integrated graphics instead of the 3080. Cut scenes in games are generally 30fps, that's how they were produced. If Cyberpunk is running well, then theoretically other games should too, not a case of the laptop underperforming. Play with the settings and go visit forums for those games to see what settings make sense for you.

Use Turbo mode for max performance, everything should be tuned already (max wattage, etc.). Use manual mode if you wish to minimize (fan) noise or prolong the battery life.

I don't know what you've installed (system optimization, etc.), whether you did anything in the registry, or updated to the latest BIOS or Windows 11 major update. Try a system reset in Windows, make sure to back up all your personal data plus the eSupport folder in c drive.!
FPS, Racing & VR Gamer / Tech Enthusiast / ROG Admin