cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Zephyrus GU501G (GU501GM) will not post., but powers on. Will not take charge.

Scionn
Level 7

I recently changed the motherboard on my GU501G(M), but it will not post. 

 

What happened to the old: Screw driver slipped when i was putting on the clip on to battery and it sparked. Not sure which though since its surrounded by a lot of components.

 

What happened to the new: i put everything on, new cmos, but i used the old screen, RAM, SSD, HDD and battery. Battery is functional. But it wont post, wont take charge, but powers on.

 

Troubleshooting i did:

Contacting ASUS (OUT OF WARRENTY, "TOO OLD")

SSD (Used a NVME instead of a SATA, because the SATA is being used on a NVME slot. Meaning i used a spare NVME)

Used a old ssd of mine to test. Didnt work.

Tried old CMOS battery, nothing

Tried "40 second" thing but does not work.

 

Only thing im left with: RAM, new motherboard again, or screen 

But when you boot the laptop, it does the sound effect on start. It didnt do that.

Please advise guys

 

*OVER ALL* Laptop wont post, wont take charge, but powers on and rgb on keyboard turns on, but then shows a blue dim keyboard. 

194 Views
6 REPLIES 6

Scionn
Level 7

Update: tried a 4gb 3200mhz ddr4 ram and it didnt work. Did not post either. Bump.

QQ02
Level 11

You can keep the battery disconnected, connect charger, see if that boots. That could help indicate if the issue is with power delivery.

My personal experience with non-booting laptops has been with damaged USB ports. I don't know if your laptop has a daughterboard for USB connectors or anything like that, keeping that unplugged can get the laptop to boot, indicating a faulty port or a faulty cable to the daughterboard (I've had a damaged cable). Beyond that you can only do a visual inspection to see if the USB ports look the same.

I replaced the motherboard on it, i forgot to mention.

I checked the ram, replaced it with. Samsung 4gb ddr4 3200mhz ram, but that didnt work.

I already removed the battery, and connected it to the charger, but it resulted in the samething. 

I shorted the old one by the way, with the screw driver touching a capacitor. 

Scionn
Level 7

Bump

QQ02
Level 11

Last ditch effort would be to disconnect all the cables, including ribbon cables, and reconnecting them to make sure they are properly connected. Sometimes ribbon cable connectors come loose during assembly if you are a bit too forceful.

Sad to say it, but if any replaceable part isn't the issue, the motherboard must be. Could have been defective from the start, could have been damaged during assembly. Some bits on a motherboard are incredibly tiny and fragile. A professional may be able to find the fault with a multimeter and previous experience (+ schematics if they can find them), but board repair is generally something best left to the professionals. If reconnecting all the cables doesn't change the fact that the computer refuses to boot, I'd try to get yet another motherboard.

Contacted the seller, waiting for response. I think the power chip is bad, and indeed, the components are fragile, i messed the last one up by having a metal screw driver slip onto a capacitor