cancel
Showing results for 
Search instead for 
Did you mean: 

Asus ROG Zephyrus G14 GA402XZ 7940HS + Qualcomm WiFi7 QCNCM865 m2 card = No sound via BT

LOCKDOC
Level 7

Dear ASUS community, hi!

I've got an Asus ROG Zephyrus G14 GA402XZ (Ryzen 7940HS + RTX 4080) laptop with terrible Mediatek WiFi 6E MT7922 RZ616 card which worked awfully. So, I bought a MSI Herald-BE PCIe wifi card which contains Qualcomm QCNCM865 m2 card inside. I pulled it out and installed into my laptop.

Wifi works great now but there is no sound through Bluetooth. I tried 3 different BT devices:

Headphones Sony WH-1000xm2

Headphones Soundcore Liberty 2 Pro

and some LG micro system.

Laptop pairs well with all of them, giving no errors or whatsoever but gives no sound through.

I tried drivers provided by MSI on a DVD and also latest available from MS - Qualcomm Atheros Communications - Bluetooth - 3.0.0.1206.cab & Qualcomm Communications Inc. - Net - 3.0.0.1207.cab

Result is the same.

My system is:

Windows 11 Pro 23H2 build 22631.3672

AMD Software: Adrenaline Edition v. 24.5.1

Nvidia drivers 555.85

Wifi drivers 3.0.0.1207

HW Id PCI\VEN_17CB&DEV_1107&SUBSYS_E0F7105B&REV_01

BT drivers 3.0.0.1206

HW Id USB\VID_0489&PID_E10A&REV_0001

Screenshot 2024-06-06 051016.pngScreenshot 2024-06-06 051115.pngScreenshot 2024-06-06 051323.png

 

 

 

Screenshot 2024-06-06 051618.png

 

 

 

 

 

I also a little bit concerned why inside my connected headphones settings is mentioned Provider: AMD

Screenshot 2024-06-06 051702_.png

213 Views
1 REPLY 1

LOCKDOC
Level 7

One of recommendations here https://support.microsoft.com/en-us/windows/fix-sound-or-audio-problems-in-windows-73025246-b61c-40f... has actually helped me kinda *solve the problem.

Знімок екрана 2024-06-06 193907.png

I had no IDT high Definition Audio CODEC in device manager, but I had AMD BT Audio device.

Знімок екрана 2024-06-06 184221.png

Driver version of which is exactly what I saw in Provider of my connected BT headphones/devices.

Без імені.png

So what I did? I change the AMD BT Audio device driver for some randomly found in the list. In my case it's High Definition Audio Device 10.0.22621.2506

Знімок екрана 2024-06-06 184339.pngЗнімок екрана 2024-06-06 194952.png

After reboot I've got an exclamation mark on it, but BT sound now works!!!

Знімок екрана 2024-06-06 194931.png

I don't count it as solution or problem solved, but at least I can use my BT headphones.

I will be grateful to listen to your suggestions\thoughts.