cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Gx 550 LWS keyboard not working after KB firmware Update tool v2.4.8

hduc201
Level 7
Hi, my keyboard not work after the KB firmware update tool v2.4.8 failed. I tried to do all the suggestion of Asus on the {keyboard trouble shooting} but it still not work. Another thing is I can't use the Asus recovery, it show a pop-up " My Asus couldn't launch in Win RE". Is anyone can help ?

Thank you!
1,832 Views
4 REPLIES 4

hduc201
Level 7
I think I found the original keymap files of this laptop , but still don't know how to use it, it have 2 CSV file for 2 keyboard layout ( mine is US)
87006
Is anyone know how to create the keyboard firmware with those files ?

Good day! We have the same problem for G732LW. Updated from Myasus app kb firmware 2.4.8 and failed, results to messing up my keyboard and rgb. I think this is a firmware issue. I already filed for support hoping for a firmware fix or something.

Blake1
Level 10
Dear both,
May you check if your BIOS has been updated and try to load BIOS default setting again?
Also, was there any error message when you are updating the firmware ?
Thank you.

Yes. I already try reupdating the bios and set it to default, the keyboard also do not work on the bios. I do have the logs on keyboard firmware update and yes it has some error, it seems it messed up my keyboard after the update.