Showing results for 
Search instead for 
Did you mean: 

2022 Zephyrus G15 System-Wide Stutter

Level 7
Ever since my purchase (In June 2022), my 2022 Zephyrus GA503RM has been experiencing a system-wide stutter. It doesn't matter what I'm doing (Gaming, YouTube, listening to music, browsing). Sometimes it happens a few times per-day. Sometimes it happens many times per-hour. Audio, display, and input (Mouse and keyboard) freeze for about 1 second when this happens. I read about several other people experiencing a similar system-wide stutter in the Zephyrus series and other AMD-based ROG:

None of the suggested fixes are helping. I deleted the Armoury Crate mobile plugin executable. The stutter happens whether or not I have Armoury Crate running. It doesn't matter which profile I'm using either (Managed by Windows or Armoury Crate).

I also read about this:

but my BIOS does not have an option to disable TPM. I haven't yet return the laptop because I hoped Asus would release a BIOS update to fix the issue. After all, how could they leave such a terrible bug in a brand new model? After installing several BIOS updates since my purchase though, I'm nearing the end of my rope.

My current BIOS version: GA503RM.310

I have tried every BIOS update since June and none of them helped. I have tried reinstalling Armoury Crate, installing the AMD provided drivers, and none of that helped either. What am I to do now? RMA?

Edit: Found a megathread:

Asus: Please send a BIOS update to fix this. It's too much.

Level 7

Yeah, I also have the same problem. It's fTMP I'm sure, but Asus just doesn't want to deal with it. They just don't care. I'm on BIOS 313, also same problem. Zephyrus G15, 2022, GA503RM.313. Someone even said, new 2023 version, don't know exact model code but also has the same problem. Ridiculous. 

i guess i should not buying this one then

Same thing on a 2023 Zephyrus Duo16, though it's not severe, but sometimes it happens constantly every 5 seconds and I have to reboot it to fix it. Idk if it's TPM related, afaik that's mandatory to be enabled for Windows 11, is it not?

It depends, maybe. I found this link: