cancel
Showing results for 
Search instead for 
Did you mean: 

2021 ROG Strix G15 nvlddmkm / "0x57 retrieving AppModel Runtime" game crashes

hobo_sands
Level 7
New laptop was working fine until I ran updates I was getting spammed with: BIOS (v315), Windows and Nvidia graphics (466.27). Since then, games freeze and automatically close but only when Armoury Crate is on turbo mode. Almost all crashes happen when the GPU is at 100% usage and frequency is over 2000 MHz, although there has been one crash where it wasn't 100% usage.

Event viewer errors show:
"Display driver nvlddmkm stopped responding and has successfully recovered."
"Failed with 0x57 retrieving AppModel Runtime status for package Windows."

Errors that have popped on frozen game after crash (not very often):
"DirectX Error..... Reason: DXGI_ERROR_DEVICE_REMOVED"
And on MW2019, something along the lines of "Dev Error"


I've installed 3 different Nvidia drivers with DDU, system restored to pre-Windows update, performed "reset this PC" (keeping files, as others online said a fresh install didn't help and I don't have anywhere else to store my games and really want to avoid having to redownload them all), disabled the Nvidia and AMD audio devices and turned off "focus assist". No success. I haven't rolled back the BIOS because only the latest version is available on ASUS' website, so it's still a potential cause.

I've been gaming on "performance" mode, which is doing the job, but this laptop was too costly to be okay with not being able to use it to it's fullest potential. Is this issue with my hardware? That it can't handle being boosted to the level turbo mode pushes it to? But again, it worked prior to the updates so I'd assume not (but I may be wrong!).

Please, I'm not sure what to do next and any help would be appreciated.
1,078 Views
2 REPLIES 2

k41n00
Level 7
Hello
i have the same problem and can't find a solution

Kornet002
Level 7

Hello, I know I am replying very late. But have you found a solution on this? I am also been getting "Turbo mode" issues regarding on the nvlddmkm driver. When I play on Performance mode, it seems to fix the issue. I have a FX706HC TUF Gaming Laptop, and I assume yours is older?

I also want to add that my laptop has automatically updated its BIOS 3 times, but I do not want to make a big deal out of this. I also performed similar actions as you did, except that I used Nvidia Cleanup rather than DDU.