Showing results for 
Search instead for 
Did you mean: 

Windows Creator Update Installation Failure on GL502VS - workaround

Level 7
Has anyone faced any issues installing the New windows Creator Update on their GL502VS.
It gets stuck at BIOS when it restart. And then roles back to the old version

This is the error i see
0xC1900101 - 0x20017 Installation failed during safe OS phase with an error during boot operation'
Help please?
356 REPLIES 356

landi.andrea wrote:
I have a GL702VM. I had the same problem with the latest Nvidia driver (which are the first set to officially support CU) thatI fixed by modifying the *inf file provided with the driver so that the hardware ID is supported by the driver. See this video:

An important step is, when attempting to install the driver, to reboot so that windows driver signature is not enforced otherwise the driver installation will fail (basically because it will understand that you tampered with the inf file of the driver). You just need to do for that for the windows session in which you will install the driver. Check "Option two" here:

I am running now 381.65 drivers and they work flawlessly. However, as many of you, I have the same problem related to update to CU.

There is also a written guide here:

Maybe it's fixed with this - if anyone tries let us know if it worked .

Ymzuki wrote:
Maybe it's fixed with this - if anyone tries let us know if it worked .

Doesn't work. It cant detect the Gforce card to install it. Any once found a solution for the Card Reader

Rishme wrote:
Doesn't work. It cant detect the Gforce card to install it. Any once found a solution for the Card Reader

Nvidia is aware of the issue on ASUS laptop, and is currently working on a fix for future stable release. Let's just wait.

At the same time, try to avoid closing lip (or pressing power button) to trigger sleep as it may cause black screen.

The fix is as simple as adding the missing Hardware IDs to the nvami.inf files. They can even copy the entries from an older driver. This is something that can be implemented within five minutes by anyone that is capable of using a text editor. That the issue still remains in the Hotfix driver shows that they simply do not care.

I am really starting to hate this laptop.

- Discharging in use.
- Overheating
- underpowered PSU
- drivers not working
- Creator's Update fails

I did not have any of these issues on my old MSI gaming laptop.

I read a post on Nvidia forums (in the topic about the hotfix driver) that they had some issues with Asus on brightness control but now they are fixed and then the support to Asus notebooks will be restored from next release. The hotfix driver didn't include Asus laptops because that it was not its purpose.
So from next release of Nvidia drivers everything should be back to normal.

edit: Installing the Creators update the way mentioned before (immediately pushing the power buttonm at the Asus logo agfter reboot), modding the inf in the hotfix driver, rebooting with driver signature enforcement disabled and installing the modded hotfix does work.

Now I am on latest driver and Creators Update, no black screen or rebooting issues.

Thanks for your help with the INF mod. I installed the nvidia driver 381.65 now. The only thing, that is not working is the brightness control. But I can live with that for a few weeks.

I was able to install the Creators Update. But I ordered my machine without an OS. I installed my own NVME SSD 960 EVO. The only thing bothering me is that the notebook won't reboot reliably each time. Almost every other time it just halts at the ROG UEFI screen.
What a mess. I really hate Windows 10 updates. Writing my master thesis rightnow. Therefore I really need a reliable computer.

Cheers guys.

You need the hoptfix driver mentioned on the side before, not the 381.65. My laptop boots reliably after installing this one. Requires the same inf mod, though.

Just to understand cause I have not tried the clean install of the Creators update working normally? (i.e. not requiring strange workarounds with the power button at startup like the upgrade) Has anyone tried it? Thanks