Showing results for 
Search instead for 
Did you mean: 

Win 11 22H2 installer not installing 0x8007001F - peripheral device problem

Level 7

I have an Asus Strix G733QSA

I have been trying and failing to install 22H2 for a day and as I've put some effort into at after being lazy and not doing anything for months on end. Does anyone have an recommendations on which drivers may need focus. As I have tried to use the Asus driver updates but it doesn't seem to have anything to do in most cases. Anyone have any clue what needs addressing as I'm quite stuck at the moment. 0x8007001F means it is a windows - peripheral driver error from setupdiag but for the life of me i can't figure out what. I've nearly uninstalled everything and am trying to update as much as possible. Not sure what is going on anyone got any recommendations? 

The following I have tried also: 

Tried using the Win 11 iso - gives me the same problem ID

Tried the Win 11 assistant tool same problem ID

Tried uninstalling VPN, Razer drivers, Logitech Cam software + drivers

Have also disconnected all peripherals whilst running installer and also tried uninstalling unused software. 

I've written a batch file to stop services run :

SC config trustedinstaller start=auto

net stop bits

net stop wuauserv

net stop msiserver

net stop cryptsvc

net stop appidsvc

Ren %Systemroot%\SoftwareDistribution SoftwareDistribution.old

Ren %Systemroot%\System32\catroot2 catroot2.old

regsvr32.exe /s atl.dll

regsvr32.exe /s urlmon.dll

regsvr32.exe /s mshtml.dll

netsh winsock reset netsh winsock

reset proxy rundll32.exe pnpclean.dll,RunDLL_PnpClean /DRIVERS /MAXCLEAN

dism /Online /Cleanup-image /ScanHealth

dism /Online /Cleanup-image /CheckHealth

dism /Online /Cleanup-image /RestoreHealth

dism /Online /Cleanup-image /StartComponentCleanup

Sfc /ScanNow

net start bits

net start wuauserv

net start msiserver

net start cryptsvc

net start appidsvc