cancel
Showing results for 
Search instead for 
Did you mean: 

USB-C port no longer works on Asus Rog Strix G712LU

Mimars78
Level 7

Today, suddenly, after leaving my mobile phone connected to the PC in question on the USB-C port and walking away for about an hour, I found the PC on standby. From now on, after turning it back on, the USB-C port no longer worked with any devices. The power supply to the connected devices also failed. Is it a hardware failure? Can someone help me? Thank you in advance

On Windows Device Manager the port still exists and is defined as fully functional. (I attach photo)

Immagine.jpg

235 Views
6 REPLIES 6

Bogus5
Level 12

Connected to the USB-C/DP port, the phone has what fast charging mode expressed in Watts ?

Mimars78
Level 7

The phone was a Galaxy s23 ultra (fast charging max 45 Watt). 

However, fast charging had been disabled on the device. 

I later tried to connect an iPhone 13 but there was no sign of any connection, neither data nor electrical.

And you previously charged this iPhone from this particular USB port ?

Mimars78
Level 7

No, it was the first time with iPhone

The trouble is that you can't charge iPhones with just anything.

It doesn't charge or connect even with a Samsung A33 5G. It doesn't charge or connect even with a Samsung A33 5G. I only use original Samsung and Apple cables