cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading Rog Stirix

diaconovi
Level 7

Hi guys,

Recently I brought a Rog Strix G16 G614JI with 16GB@4800Hz, I'm planning to upgrade it, but couln'f find the techninal manual, as Asus is very greedy with the documentation, I would like to know if this laptop supports ram 32GB x2, also if I can upgrade  the bus to 5200Hz or 5600Hz.

Btw I also planning to add an other 1T nvme, which heatsink should I buy?

Regards.

Diaconovi.

709 Views
27 REPLIES 27

dimVLG
Level 8

Hi. I put 2x16 SODIMM Kingston FURY Impact [KF556S40IBK2-32] 5600. Everything works fine at a speed of 5600

Hi, great news, could you tell please the exact laptop model you have?

Surkoff
Level 7

Have you tried eventually 5600Hz is ok? for your Rog Strix G16 G614JI ?

Yes, that's right, I have 5600Hz 32gb and SDD Samsung 980pro

pepe999
Level 9

Hi,

2 x 32GB of 5600MHz should be a piece of cake but the higher frequency modules have also higher latency(38+). I have just put 32GB - 2x16GB of 4800MHz G.Skills with latency 34 into my G614JZ. I have also put a second NVME(500GB Samsung 970) without a heatsink and there is no heat anywhere. CPU is at 27* and with the dVGA(MUX) on, the 4080 is at 38* while watching youtube and other general internet stuff. I'll probably put a QHD LCD in it too but prefer a 3K LCD if possible. 

a3x05
Level 9

@pepe999 Hi, I just saw your comment and I'm a bit baffled about your temp claims. I have the G614JI (same as yours apart from the panel and the RTX4070) and get idle and browsing temps around 47°C CPU all core max (-80mV) with a room temp of 28°C. GPU around 40°C when active. Under 100% load during TimeSpy the GPU reached 80°C which I'm fine with, however, the CPU tops at 98°C which is a bit much in my opinion...

Which fan curve have you set? Undervolt?

I'm on linux Manjaro so no unnecessary processes running in the background like an antivirus or the gigabytes of bloatware that come with the stock Asus Windows. I'm also running only the RTX4080 so if you are on a hybrid graphics the CPU has probably the iGPU active. Everything is stock fresh install. I'm not exactly a gamer and play only the X-Plane sim. 

@pepe999 You are right, I instantly did a fresh Win11 install and killed all Asus processes with GHelper. Still I can't get my head around how a temp of 27°C is possible (at which room temp btw?).

I don't game either, it's a workstation to me for developing, virtualisation and so on. Core estate help there nicely^^

Have you ever tried benchmarking? What's the max temps you had?

Seems like my conky has used a wrong input. I just ran sensors-detect and sensors and the temperature is 49 degrees. Looks like the conky acpitemp used data from virtual sensors that are not supported in the kernel yet.