Showing results for 
Search instead for 
Did you mean: 

Strix Scar 17 Problem with sudden stuttery display, help please

Level 7
So, I recently got an ASUS ROG Strix Scar 17 laptop. For the most part it works great, but there's this one issue that's been bugging me more and more as of late. At seemingly completely random times, both the display and the audio of my computer will become incredibly stuttery for about a second, to the point that the audio play out like th-i-i-i-i-s-s-s-s for about a second before suddenly fixing itself. It was pretty rare at first so I just ignored it, but it's now becoming noticeably more frequent. I've tried driver updates and tweaking with different settings but nothing's fixing it, does anyone have any ideas as to what could be causing this? Thank you.

AMD Ryzen 9 5900HX with Radeon Graphics 3.30 GHz
NVIDIA GeForce RTX 3080 16GB GDDR6
360Hz IPS FHD Display

Level 12
check you using the latest AMD drivers

and Nvidia Drivers.

Also check your network NIC is on the latest driver.

I have the same problem as you say , try to post it about half year ago but no answer from ASUS. My model is Strix G733QS Ryzen 7 5800h with RTX 3080 8GB . I try many way to solve it but it did not work at all.
List of what I try.
1.Reinstall Window 10.
2.Install Window 11 instead.
3.Clean graphic driver and reinstall , Clean audio driver and reinstall.
4.Try to update all the driver .
5.Uninstall armoury crate.
6.Clean install window and did not install armoury crate and any other asus software .
Nowaday still live with it. expensive laptop with **** issue. I'm not sure that it's a defect of my product or it cause from the software of ASUS.
and also in REDDIT , There're many people ask about this.

Level 13
Sounds like a typical vrr overheating (the small mosfets lines above the CPU)
// ASUS SCAR18 G834JY, i9-13980HX, 4090 256bit 16GB, 32GB 5600MHz RAM, 18" 16:10 2560x1600 240Hz G-Sync internal screen, external UWQHD 3440x1440 Mi 34" Monitor with Freesync, NVMe, 8BitDo Arcade Stick, EasySMX X10 controller, ROG Strix Carry mouse.

I got a good news for you it is a bug from AMD CPU when enabling ftpm so it will be fix soon.
In PC can be fix by turn ftpm off but in laptop it doesn't exist and also window 11 need it. just waiting for bios patch
Example of stutter :

any update to this? has the fix for it been deployed yet? I still get this issue myself on my G17RS

Level 7

I also still have this problem, anyone got any fix?