Showing results for 
Search instead for 
Did you mean: 

Strix G15 Problem connecting to dock USB-C

Level 7
I just bought a ROG Strix G15. To make my life easier I also bought a USB-C docking station from Targus.

When I connect to the docking station to the computer using USB-C nothing happens. However if I put an USB3.0 adapter on the cord so that I can connect the dock to my computer using USB3.0 it works all of a sudden. However I did not by this dock to connect through USB3.0. I want to use USB-C. It's a USB-C dock and the new Asus laptop comes with one USB-C port.

I've got the MyAsus application and so far as I can tell everything is up to date (does it update drivers by itself?). Can I check manually somehow that the USB-C port on the computer works? What could be a possible cause?

If you look at the specs for the computer it states the following on the USB-C port: "1 X USB3.2 Gen2 Type-C support DisplayPort™". Does that mean I must connect my screen to the dock using displayport? It works with HDMI when I connect the dock to the computer using USB3.0.

Very grateful for any help!

e: When I have the adapter plugged into the computer the USB-C connection works. If I remove the power cord the connection breaks. But isn't it odd that the connection to the dock works if I connect through one of the computers USB3.0 ports? What gives?

This is the dock I bought and it's supposed to supply the computer with power up to 60W.

He solved it for me to unplug the battery.
But it’s not a solution in the long run to always unplug the battery!:mad::mad::mad::mad::mad:

Does anyone know a better solution?

I used the My Asus app and did all the updates, installed the latest intel video driver from intel (not ASUS) and it seems to have solved it for me at least.

Bad news. After nearly two years of malfunctions, loss of time and frustration, in September 2022 the problem is officially recognized and the solutions published; "[Notebook/Desktop/AIO] Troubleshooting - How to fix USB Type-C problems". Unfortunately for us, the basic problem is not solved and the solutions proposed are those that I have been applying for two years. They often come down to a complete restart of the computer. For me, it's not a financially viable solution if it forces me to waste a day of work repeatedly trying to solve this basic operational problem.

Level 7
First and foremost, USB-C is a connector type, which can carry protocols such as Thunderbolt 4, Thunderbolt 3, USB 3.0, USB 3.2 gens 1x1, 1x2, 2x1, 2x2, and USB4. So, now you should be able to see why this does not make sense:

JoarS wrote:
"However I did not by (sic) this dock to connect through USB3.0. I want to use USB-C.

BTW, it looks like the link to your specific dock has expired, so your link just sends me to a list of 15 docks:

JoarS wrote:
This is the dock I bought and it's supposed to supply the computer with power up to 60W.

In any event, you won't be able to charge your laptop with only 60w, but your other USB peripherals could use this power to run or to charge. Sorry that I don't have enough context to help fix your problem, but this backgrounder should help you find the answer.
- mBrane

ASUS Rampage IV Extreme, Intel 3930K @ 4.4 GHz, 32 GB Corsair Dominator (liquid-cooled)
2xEVGA GTX 680 Hydro Copper @ PCI 3.0, Samsun Evo 860 SSD
Aquaero 5 Pro Controller w/ waterblock
7x120mm Thermochill Rads 7x120mm Gentle Typhoon 1850s
2xSwiftech MCP35X pumps w/ EK Acetal Dual Top @ 82.5 gal/h
EK Acetal+EN blocks on CPU, RAM, Northbridge, Southbridge, and VRMs

28c idle, 38c under load, nice and quiet!