Showing results for 
Search instead for 
Did you mean: 

Strix G15 Problem connecting to dock USB-C

Level 7
I just bought a ROG Strix G15. To make my life easier I also bought a USB-C docking station from Targus.

When I connect to the docking station to the computer using USB-C nothing happens. However if I put an USB3.0 adapter on the cord so that I can connect the dock to my computer using USB3.0 it works all of a sudden. However I did not by this dock to connect through USB3.0. I want to use USB-C. It's a USB-C dock and the new Asus laptop comes with one USB-C port.

I've got the MyAsus application and so far as I can tell everything is up to date (does it update drivers by itself?). Can I check manually somehow that the USB-C port on the computer works? What could be a possible cause?

If you look at the specs for the computer it states the following on the USB-C port: "1 X USB3.2 Gen2 Type-C support DisplayPort™". Does that mean I must connect my screen to the dock using displayport? It works with HDMI when I connect the dock to the computer using USB3.0.

Very grateful for any help!

e: When I have the adapter plugged into the computer the USB-C connection works. If I remove the power cord the connection breaks. But isn't it odd that the connection to the dock works if I connect through one of the computers USB3.0 ports? What gives?

This is the dock I bought and it's supposed to supply the computer with power up to 60W.

Do you have another USB c cable to try? Do you or a family member have a USB-C compatible phone to test the port? Otherwise you might have to use more adapters to connect an older USB device to the type c port for testing.
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

A couple of days ago it just started working when I connected the laptop to a power source. However I can't get it going again. The laptop is currently connected to it's ow power source as well as the dock but there's no interaction. I cannot get it to work.

Can I manually search the ports and get the computer to understand that it's connected to a docking station via the USB-C?

it could be a power issue with the laptop. it may only provide power to the USB Type-C port when a particular device is detected to try and save power.
when running on battery alone, it may disconnect any type of super-speed charging device to save laptop power. but then I would expect it to work when the laptop's own power cable was connected.
does the laptop have any settings via BIOS or control software that allow you to change settings for it's USB port you are connecting to?

it could also be an issue with Windows power settings powering off the port in certain instances.

or it could be an issue with the device itself, possibly needing drivers downloaded directly from Targus.
ASUS ROG Strix Z590-E Gaming | i7-11700K \ ASUS ROG Ryujin 360 | G.Skill TridentZ 3466 CL14 32GB | ASUS TUF RTX 3080 Ti | M2: 960GB \ SSDs: 5TB \ HDs: 16TB | Super Flower Leadex III 850w | Fractal Design Vector RS Blackout \ 5x be quiet! Silent Wings 3 140mm High-Speed PWM | Logitech G600 | Corsair K70 LUX RGB | Xbox One S Gamepad | Klipsch ProMedia 2.1 | Anker Soundcore Life Q20 | 34" Alienware AW3420DW \ 55" LG CX OLED | Windows 10 Pro x64

JoarS wrote:
A couple of days ago it just started working when I connected the laptop to a power source. However I can't get it going again. The laptop is currently connected to it's ow power source as well as the dock but there's no interaction. I cannot get it to work.

Can I manually search the ports and get the computer to understand that it's connected to a docking station via the USB-C?

TL;DR: tried charging my laptop with my phone charger from the wall... broke some stuff.. seems to be fixed after abit of tinkering.

So, i noticed alot of laptops can be charged with Usb-c recently.. and then i saw my laptop also had this function.
However it is recommended to use the proper chargers and not use non-taylored items, alot of information online hints that with the stardardized USb-c ect the risks were negligable.

So, then i decided on a whim to plug my phone charger into the wall and then connect the usb-C to my computer.
-just to see whether it would at all recognize the charger applying any minute amount of electricity to the battery.. not that i ever intended to do such a thing extensively.

what took me by surprise; was that even though i only had the thing plugged in for litteraly 10 seconds... checking that nothing was happening and giving up on the idea and unplugging,
when i connected the normal charging brick, it didnt charge, and it didnt recognize the charger.

so to keep it short:

-I checked the battery with the diagnotic program. it was fine.
-I tried deactivating and reactivating the drivers for the ac stuff, but nothing changed.
-I also uninstalled and reinstalled the drivers.. no difference.
-I tried to restart the computer, to no avail.
-i tried to shut it down, and power it back up, .. no change.
-I tried disconnecting and reconnecting the power supply in different ways, with no luck

I then shut the thing down and opened her up
-I then disconnected the battery and tried to restart with only the power supply ... it wouldnt start...

but alas, i had given up,
-I then reconnected the battery and turned her back on, and there she was, charging and all.

I have no idea what damage this may have caused to my computer.. but i definitely wont do it again.

Just wanted to share this in case someone were wondering about doing something similar, or were facing a similar problem.

-Asus Rog Strix G512LW
-Huawei Phone charger 2-4A, 5-9-10V, 40W
(note charger slightly damaged with some exposed copper wire, but still charges phone normally, even after all this
-European 240V outlet
-yes i know i am stupid

I saw enter the Bios 2-3 times it will solve it until the next reboot, I thought the problem was the password in the Bios but it doesn't. It only happens when I turn off the computer connected to the dock station.

guero2099 wrote:
I saw enter the Bios 2-3 times it will solve it until the next reboot, I thought the problem was the password in the Bios but it doesn't. It only happens when I turn off the computer connected to the dock station.

It seems I might have found a solution. For myself, I could replicate both the issue and the solution since finding it.

TLDR: You need to plug the power in before the dock.

It had me wondering for months why my Genki Covert Dock wouldn't work with my Strix G15 G512LV. Sometimes it only worked when it was unplugged, sometimes it would work when plugged in and most of the time it wouldn't work at all. Unless, that is, I turned the laptop off, unplugged everything and started it up on battery. Then, I had to plug in something unpowered and that requires low power (I mostly used a Genki Bluetooth Receiver, I know, It's like a Genki ad at this point, but alas). That then started flashing and working but ONLY after the power down and restart from battery, never on its own.

Flash forward a few months, my work laptop died and the new one I got came with a fancy dock, one that has a built-in LED in the USB-C connector. I set it up, thinking that it the issue was just my Genki Dock somehow and that an expensive Dell dock should work. And it did. And then I took the laptop off, used it elsewhere and when I plugged it back in, the LED wouldn't even come on. And then next time I plugged it in it worked. And I played around with it and the LED always comes on when I plug it in AFTER the power cord. If I do it in reverse, it NEVER works but if I plug them in in the correct order, it ALWAYS does.

Also I have to mention that just before, I enabled "Erp" in the BIOS, but reading up on it, it should have nothing to do with it, but I thought I'd mention it.

So it's at least worth a try for all you folks struggling with a dock setup with these machines. It works for me consistently now as long as I plug the cables in in the right order.

Good luck guys!

Level 10
Hello JoarS,
Please kindly PM me your SN
and provide a picture of the dock, together with the model name as well.
Thank you so much.

Unfortunately I have the same problem and couldn't find a solution to help you.

I bought a ROG Strix G15 G512LI specifically for its USB-C 3.2 Gen 2 port. I plug into my Kensington SD4800P docking station through this port. This dock works great on my other HP and Toshiba notebooks, via their respective USB-C ports.

Initially, I plugged in my docking station via the USB-C port and everything was working fine. The next day I did the updates and the USB-C port stopped working.

I reset the laptop to factory settings, this fixed the problem for a few weeks and after restarting the computer, the USB-C port no longer worked.

I did all the updates through MyAsus and on the Microsoft side with Windows 10 V2004, and on the Kensington side for the driver.

The Microsoft technician validated the drivers and other parameters related to the USB-C port, without success. Since plugging the dock into the USB-C port does not trigger any detection of a new device, it questioned the Intel USB 3.0 Extensible Host Controller Driver for Windows * 8 and Windows 10, which would no longer be produced by Intel;

however, if I plug a Toshiba travel dock into this USB-C port, the mouse plugged into that device works.

Any other ideas?

Thank you for any help!

Three years later, I have the same problem. I ask Chat GPT why the problem is still present. Interesting answer, especially point 4.;   

The intermittent detection issue of USB-C ports on the Asus G512LI Strix laptop running Windows 10 can be challenging to debug and resolve due to various factors. Here are a few possible reasons why this issue might be difficult to debug:

1. Complexity of the issue: Intermittent detection problems can be complex and difficult to reproduce consistently, making them harder to diagnose. If the issue occurs sporadically and is not easily replicable, it can be challenging for developers or support teams to pinpoint the exact cause.

2. Combination of hardware and software factors: The detection of USB-C ports relies on a combination of hardware (the port itself, connectors, cables) and software (drivers, firmware, operating system). Identifying the root cause requires thorough investigation and analysis of both hardware and software components, which can be time-consuming and complex.

3. Compatibility and driver issues: USB-C is a versatile and rapidly evolving technology with various standards and specifications. Compatibility issues between USB-C devices, cables, and adapters can arise, leading to intermittent detection problems. Additionally, outdated or incompatible drivers can contribute to the issue. Resolving these problems often requires collaboration between hardware manufacturers and software developers.

4. Limited resources and priorities: Debugging and resolving issues require time, resources, and expertise. Manufacturers and developers need to prioritize their efforts based on the severity and impact of the issue. If the intermittent detection problem is not widespread or affecting a significant number of users, it may receive lower priority compared to other critical issues.

5. Unique system configurations: Each user's system configuration can be different due to various software installations, drivers, peripherals, and settings. Identifying a specific pattern or commonality among affected systems becomes more challenging when dealing with intermittent detection issues.

6. Communication and collaboration challenges: Debugging and resolving complex issues often involve collaboration between different parties, such as the laptop manufacturer, USB-C chipset manufacturer, operating system developers, and third-party software developers. Communication challenges and coordination among these entities can sometimes slow down the debugging and resolution process.

It's worth noting that manufacturers and developers actively work to address such issues through driver updates, firmware updates, and collaboration with users reporting problems. If you are experiencing the issue, it is recommended to reach out to the Asus customer support team and provide detailed information about the problem, including your laptop model, Windows version, driver versions, and any other relevant details. This will assist them in investigating the issue further and providing assistance.