cancel
Showing results for 
Search instead for 
Did you mean: 

Strange Intermittent GL502VMK Keyboard (Keys) Problem - Really Desperate

rEaDy_
Level 7
Hello,

1 year ago I bought my first ASUS ROG laptop, the GL502VMK (7th generation) model.

Everything was fine until about 2 months ago when some keys (E, G, H, F2, F7, PRINTSCRN, -, \, ->) started to not work from time to time. At the beginning the moments were very rare when they wouldn't work and usually get back working really fast, but after around 2-3 more weeks they started to stop working almost all the time and rarely would work. I tried to find a solution for my problem everywhere on Internet but nothing worked. I reinstalled windows multiple times, keyboard driver, etc.

The problem persisted even on bios so it made me think it's 100% not software related.

But the strange part only comes now: Anytime I kept shift or any other key clicked before clicking on the unresponsive keys they would work 100% normally, but only if another key was pressed while they were pressed as well, if I pressed only them it wouldn't work.

So I sent my laptop into service where I have the warranty. After 2 weeks they sent it back to me saying that they couldn't reproduce the problem and everything looked fine on their end (it passed all stress tests and etc.) - I was a bit confused, and I was even more confused that when my laptop arrived from service it actually didn't had the problem anymore (even if they said they didn't even saw the problem). I was very happy and started to use it again. But now after few weeks the problem re-appeared, developing every day into harder and harder responsive keys and now it again doesn't work anytime only if I press other keys before them.

I am really desperate about this problem and I don't know what to do anymore. If I'll send the laptop again in service I will lose it again for 1-2 weeks (and I can't afford that) just to come back and tell me again they couldn't reproduce the problem.

Anyone have any thoughts about this? Really appreciated.

Thanks!
1,756 Views
2 REPLIES 2

rEaDy_
Level 7
Nobody? 😕

Problem is still here...