Showing results for 
Search instead for 
Did you mean: 

ROG Strix Scar II GL504GW - Disable/Toggle touchpad not working using Fn+F10

Level 10
Hello everyone, I have really searched all the ROG forums and googled comprehensively before creating this thread to make sure I'm not duplicating. So here is my problem:

System: ROG Strix Scar II, GL504GW
Windows 10 home 64bit, Version 10.0.18363 Build 18363,
BIOS version GL504GW.305

Recently I RESET MY PC for a separate problem and after re-installation noticed that (Fn + F10) key combination for "disable touchpad" is not working. Also clicking the touch pad button in Armoury crate does nothing i.e. touchpad cannot be disabled in Armoury crate. All other Fn keys F1 to F12 are working properly including volume buttons and ROG key. I clarify that my touchpad itself is working without problem, I only can't toggle by Fn+F10

Troubleshooting done by me so far:

(AA) RESET THIS PC again through Windows 10 Recovery. I chose to delete all files & settings while using this option.

(BB) Installed automatic updates through MYASUS app.

(CC) Uninstalled and re-installed latest ASUSKeyboardHotkeys service (drivers) from ASUS product support page.

(DD) Uninstalled and re-installed ASUS Hotkeys from Windows store.

(EE) Verified that latest drivers are installed for ASUS PRECISION TOUCHPAD, same as on support page.

(FF) Uninstalled and re-installed latest version of ARMOURY CRATE SERVICE from ASUS support page.

(GG) Uninstalled and re-installed ARMOURY CRATE from Windows store.

(HH) Used ROGKBFWUpdateTool_V1.0.8_from ASUS support page. It found that my keyboard is already updated.

(II) Checked in windows device manager that drivers for Intel Serial IO controllers are the latest versions, same as ASUS support page.

(JJ) Ran SFC scan and DISM commands from Command prompt. No errors were found.

(KK) Verified that BIOS is latest version as on ASUS support page. I loaded default settings in BIOS and saved.

All of the above steps did not solve the problem.

In Windows device manager, I noticed YELLOW EXCLAMATION MARK on "ASUS Number Pad" which is listed under "Keyboards" (Attached screenshot).
Trying to automatically update the driver, windows says that latest drivers are already installed for this device. If I choose to browse for drivers on the computer >> install a driver from a list of available drivers on my computer >> choose "HID Keyboard device" instead of ASUS Number Pad.
Then the Yellow exclamation is removed and the ASUS Number Pad in device manager is replaced my one more HID Keyboard device (there was already one by same name). After this the Fn + F10 started working for disabling and enabling the touchpad.
I am wondering if this is actually the correct driver for this device (whatever this Number Pad is) because it seems I have ASUS precision touchpad and have proper drivers installed for that.
I would really appreciate if someone could point me to the correct driver for ASUS Number Pad to remove the error in device manager.

At the least, it would be very beneficial to me if someone could post a screenshot of their device manager with Keyboards and mouse expanded.

Thanks all

Level 10
I need some help guys, please post a screenshot of your scar II device manager 'Keyboards' tab.

Level 10
Hello vashish27,
Please kindly send your device to the service center.
Thank you.

Hey Blake,
Thanks for reply. But I am quite certain that it is not a problem with hardware (touchpad and keyboard are working fine as is). The service center will most likely just install the original OS and when windows updates automatically again, I may again face the same problem.
This is most likely a driver issue which so far I have deduced by own troubleshooting. Just want to do as much as I can on my own before visiting the service center.

Hey there
i have the same issue with the same device and actually you're in the right place 😄 , all you have to do is click on the device and then properties / driver and roll back driver and it will work just fine , lemme know if it worked for you because it did for me :cool:

Hey Azain,
Thanks for replying. Actually I "RESET MY PC" with 'remove everything' option, hence there was no option for me to roll back to previous driver.
But I manually selected HID Keyboard device driver instead of ASUS Numpad and the problem was solved.