cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Strix Scar II GL504G Battery Problems

Ajax_Gaming
Level 7
Hello,

After my battery to my Strix Scar II hit zero it now refuses to charge. It is just stuck in 'plugged in' and zero percent battery.

I thought maybe I needed to update the system so I did but the problem persists.

Not sure if software or hardware related. I did order a new battery but want to troubleshoot before I open it up - I'm not exactly comfortable doing this yet.

MyAsus found no issues with the battery. Battery report says its capacity is still full, allegedly, and HWMonitor puts its wear level at only 5 percent.

It did go without a charge for probably 6 months while I was moving / it was kept in storage in a warm environment. So it's possible it just died for good?

It seems like this is a pretty low level/low quality battery, but I want an operable battery in case I ever lose power or it becomes unplugged by accident.

Again, I have a replacement battery that I can try, but I ultimately want to rule out that it is not software related first.

Anyone run into this same issue? I tried uninstalling/reinstalling drivers for the battery/adapter but no dice.

Do not think the adapter is the culprit, it's getting the proper voltage and powering the laptop and running games fine.

The LED light is a solid Orange so it is recognizing the battery. But it is not charging the battery.

I have not yet disassembled anything or removed the battery. It seems like an easy job but I am a rookie with this and nervous to tinker with it.

Advice before opening this up? Probably seems like opening it up is the only way it's getting fixed. I feel like I tried all of the software stuff.
751 Views
0 REPLIES 0