Showing results for 
Search instead for 
Did you mean: 

ROG Strix SCAR 17 G733 G733QSA-KH097T

Level 8

Hello, I have a persistent problem: the graphics card in my laptop automatically turns on in eco-mode when the system starts in Armory Care, when I want to switch to standard or optimized, the application slows down with the inscription switching, the graphics card is detectable in the device manager and drivers can be installed for it


You can try to reinstall the Nvidia drivers and install the latest also if you have the latest drivers reinstall them another thing is when you reinstall the drivers check in Nvidia control panel and set up everything to use RTX graphics also 

Also if this dont work try ehit "iobit driver booster 11" download it from the official site update all drivers and check then 

I also tried Iobit driver booster some people say apps like this can make a problem and i know it but for me work perfect and install the correct drivers 

When you update all your drivers delete the program you will no needed anymore only when you install the drivers check if you have a driver for SSD storage uncheck this and dont update SSD 

Try this becouse i think the problem can be of missing drivers or faulty driver instalation 

Maybe whit the reinstallation of the Nvidia drivers the problem will be fixed and dont forger to restart your PC 

If the problem is resolved whit Nvidia drivers reinstall you can skip this iobit driver booster

Level 8

I tried to reinstall the drivers, they install normally, but when I want to enter the nvidia control panel, it does not open, the circle next to the cursor spins and nothing happens. I also tried to boot the system in safe mode and use DDU to uninstall the drivers and perform a clean installation, but with no results. I will also add that in the HWInfo program it shows the dedicated card but does not show the VRAM memory

Very strange problem in this case if you try everything you can create a image back up file on external device and try to reinstall the windows maybe this will help if not help maybe you have a faulty GPU and the problem is more serious

Back up file will restore your system to 100%

I installed the system and Windows 10 and Windows 11 do not help. I still have one question because I discovered that the matrix is ​​not original, is there a substitute? Could it cause a problem with the graphics? I'm sorry that I discovered it so late, but I bought a second-hand laptop and I had to figure it all out on my own

I am not 100% sure but i think this is not a problem becouse even if the matrix not original you must can use your RTX graphics you can try to connect  external monitor if you have to see what will happen and if you allowed tou use your RTX graphics whit external monitor than the problem is there but i think when the problem stay even after windows reinstallation can be something more serious than a software bug or faulty windows drivers becouse after windows reinstall everything is fresh and new and mustn't have a problem also you write about that you dont have this option

If you dont have this option (that bios whit mux switch must support) i think you can have a faulty GPU faulty,GPU memory becouse i dont think that the matrix change or test on external monitor can cause or can fix whit problem like this


If you have near and good laptop service send it or if some asus support see this post they can give you advice where to send your laptop and what you can do whit the repair of the problem

I sent the laptop to a specialist service for diagnosis, it is possible that it will be the VRAM power section, at least that's what I bet because the card itself is detectable in the BIOS and the system. thx for help