cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix G731GT USB ports no longer working

CraigHammer
Level 7

Hi everyone,

I restarted my laptop the other day and when it rebooted, none of the USB ports were working. I've tried every and any USB related troubleshooting I can. If anyone has a suggestion I'm all ears! Here's the important information:

- None of the USB ports (all USB A size, with blue interior which I think marks them as USB3 compatible) recognize any USB device. Tried mice, keyboards, webcam, USB keys and external HDD.

- The USB ports don't appear to recognize anything in the BIOS either

- Ran every update I could find, including installing all of the latest drivers from the Asus / ROG support site. 

- Made sure windows was updated completely

- After this didn't work, I rolled back to the earliest restore point I could find (which was unfortunately not that long ago, I think the same day the issue started).

- I have since re-updated everything to the latest versions again

- uninstalled all USB drivers from device manager. Note: when i do this and hit 'scan hardware' before restarting, nothing appears. Upon restart the same USB drivers all get installed automatically. It's as if the hardware isn't being detected?

- tried installing random legacy drivers to see if any of these worked. no luck and it stopped my integrated keyboard working, so I changed it back to the regular drivers.

- opened the case and removed the battery, left it unplugged for about 5 - 10 mins, tried cycling the power button while it was unplugged to drain the power completely. plugged battery back in, put everything back together. no luck

- tried all the power management options for USB drives, disabling any possibility of them being shut down for power saving reasons

- enabled and disabled legacy support for USB in bios , neither option works.

- Asus support suggested putting it in for repair but its out of warranty and I'd probably prefer investing in a new laptop if I have to rather than pour money into an old machine.

 

Anyone have any possible solutions? I thought it was a driver update from windows update that caused it, but  with the BIOS also not detecting anything USB, I'm wondering if it is a bios or firmware problem? Any hints?

 

Thanks

109 Views
0 REPLIES 0