Showing results for 
Search instead for 
Did you mean: 

Rog Strix G531GV supported NVMe drives

Level 8

Hello recently I bought the aforementioned laptop and today when I tried to upgrade the included 500GB Mikron PCIe Gen 3 x4 NVMe SSD to a 1TB SK Hynix with the same specifications the laptop refused to boot.
It wouldn't enter Windows nor the BIOS while the SSD was installed and so I tried reseating it, removing it and disabling fast boot, secure boot, reverting to BIOS defaults, removing the SATA SSD and even installing an older BIOS version as a latch ditch effort and none of this worked.

After some digging I found that some others had issues using NVMe drives on Asus laptops and Motherboards so I was wondering which ones would be supported, I heard people had more luck with Crucial and Samsung for example the P3 and 980 drives. I would be grateful if someone could confirm or suggest some other SSDs that they had luck with when using it on the aforementioned laptop.


Level 8


Maybe this piece of information helps. in my G531GV i have pre-installed the Intel SSDPEKNW010T8 which is a 1TB ssd nvme. 







Level 7

Hey I just tried upgrading with Crucial P3 but with no luck. If you have fixed the issue do you mind letting me know please.

Hello, unfortunately I didn't manage to fix it. Apparently the board just doesn't play nice with some nvme controllers but I don't know which ones exactly.

Although considering Crucial confirms the P3 to be 100% compatible and it still doesn't work is pretty bad not gonna lie, especially since I planned to try that one too.

In either case I went with a Samsung 980 that one worked perfectly for me, hope this helps.

Thanks for getting back. Yes I'm in the process now with Crucial to see what the score is. Hopefully get a replacement or refund or just to get it to work. 

Best of luck, hopefully they will at the very least refund you or replace it with a model that works with this laptop.

I have the same issue. 3yo G531GV that came with a SATA SSD, despite the seller listing it as nvme. The crucial p3 isnt detected, device doesnt go into bios at all, stuck at logo. I think mine only supports SATA M.2 and I just never noticed.

It definitely does but it seems to be really picky about the NVMe controller on a lot of SSDs. I'm not knowledgeable enough to know the exact issue or cause but it's hit or miss it seems. I can attest that the Samsung 980 NVMe works and someone mentioned an Intel SSD to work with it as well.

Try ones with return windows where they take it back without question and see if one of them works in either case best of luck to you.