cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix G - G531GV - RefreshRateService not working as intended

partaloski
Level 7
The problem with my laptop is that the Panel Overdrive option is nowhere to be found, even with installing and reinstalling Armory Crate, RefreshRateService, and even clean installing Windows 10 with all of the given installs on the product support page the result is the same thing over and over again, Armory Crate with no Panel Overdrive option.

The RefreshRateService is running when seen in Services (services.msc) and I have tried restarting both it and the ArmoryCrateService service, and that has done nothing to my problem, I have tried older versions of RefreshRateService and gone back to the first one I could find and that did nothing, the updates in Armory Crate are all done and there are no updates that are waiting to install and I feel helpless knowing that my panel runs at this setting where the ghosting is just too much, especially for players like me (FPS Shooter player).

Has anyone ever encountered a problem similar to mine and if so how did you guys resolve it?

One of the pictures is what I am able to see and the other is from a picture I found on the internet when looking up Panel Overdrive for this model of laptop.

90447
90446

All of the versions of all software related to Armory Crate - as generated in the application itself are:

  • Item Version
  • ---- -------
  • Armoury Crate UWP App 4.2.12.0
  • ROG Live Service 1.2.18.5
  • AURA Service (Lighting Service) 3.05.18
  • Armoury Crate service 4.2.10
  • ASUS Aac_NBDT HAL 2.5.3.0

1,304 Views
1 REPLY 1

GL531GU
Level 7
partaloski wrote:
The problem with my laptop is that the Panel Overdrive option is nowhere to be found, even with installing and reinstalling Armory Crate, RefreshRateService, and even clean installing Windows 10 with all of the given installs on the product support page the result is the same thing over and over again, Armory Crate with no Panel Overdrive option.

The RefreshRateService is running when seen in Services (services.msc) and I have tried restarting both it and the ArmoryCrateService service, and that has done nothing to my problem, I have tried older versions of RefreshRateService and gone back to the first one I could find and that did nothing, the updates in Armory Crate are all done and there are no updates that are waiting to install and I feel helpless knowing that my panel runs at this setting where the ghosting is just too much, especially for players like me (FPS Shooter player).

Has anyone ever encountered a problem similar to mine and if so how did you guys resolve it?

One of the pictures is what I am able to see and the other is from a picture I found on the internet when looking up Panel Overdrive for this model of laptop.

90447
90446

All of the versions of all software related to Armory Crate - as generated in the application itself are:

  • Item Version
  • ---- -------
  • Armoury Crate UWP App 4.2.12.0
  • ROG Live Service 1.2.18.5
  • AURA Service (Lighting Service) 3.05.18
  • Armoury Crate service 4.2.10
  • ASUS Aac_NBDT HAL 2.5.3.0


You aren't the only one.

I have the exact same issue on my ASUS ROG G531GV.