cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix G G531GT side/bottom leds not working

Karellen23
Level 7
Hi!


My laptop's side leds are not turning on.

At first when I bought the laptop it was working, but after changing some keyboard rgb settings in the aura core app, it just stopped working.

Also, I can only see the keyboard in every aura application, and not the sidebars. This was the case the first time I installed Windows too, so it didn't happen after it stopped working.

Contacted Asus support, they said I should reinstall Windows without internet, and install the drivers from the Asus website. I did that multiple times, but the side leds are still not showing up in aura, and are still not working.

After that I read somewhere, that fully draining the battery might solve this issue, tried it, and it didn't work sadly.

Specs are: Windows 10 Pro 64 bit, GTX1650, i7 9750h, 8GB ram, 120hz full hd display

Is anyone else having this problem with these newer laptops?

Could someone help me please?
68,926 Views
20 REPLIES 20

jdfrench3
Level 12
After installing Windows 10, are you using the AsInsWiz.exe found in your eSupport Folder and reinstalling all the ASUS support programs and drivers? There's a lot of data that's installed in the background to support your ASUS programs. ASUS Download Site doesn't have everything you need to restore full service.

You did keep a copy of your eSupport Folder?
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

I had no idea there was a folder like that.

Where was this located?

When I bought the laptop the SSD was empty, at least I couldn't see anything on it.

Edit: I did not have an OS installed on the laptop when I bought it.

The eSupport Folder is located on your OS drive.

I would return the laptop to who you bought it from. If that doesn't work, then get a ASUS RMA and return it to ASUS and have them restore your storage device to new.

Good Luck
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

My laptop did not have an "OS drive" when I bought it.

Are you absolutely sure this is needed?

If you want to get the laptop back to OEM you need the original programming on the ASUS OS storage device.

I have a site that has many of the eSupport Folders (ASUS Support DVDs) but your model is too new.

How the heck did you come by this laptop without an OS? Does the guy you bought it from have the original SSD or was it wiped?

Is the laptop under warranty?
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

The laptop is factory new. I bought it from a Hungarian retailer. It is commonplace here, to buy laptops without OSs.

I contacted Asus support about this esupport folder.

Edit: The laptop has 36 months of warranty.

Take a look at my Sticky post at the top of the G Series Gaming Notebooks forum page.
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server

I got it working by uninstalling everything. And after that installing the Armoury Crate UWP app, the service it needs, and the ASUS hotkey app.

After that in the Armoury Crate I clicked Device/System/Lighting and "Reset to default" fixed it.

80878

Karellen23 wrote:
I got it working by uninstalling everything. And after that installing the Armoury Crate UWP app, the service it needs, and the ASUS hotkey app.

After that in the Armoury Crate I clicked Device/System/Lighting and "Reset to default" fixed it.

80878


Thanks for this, I'm gonna try this when I get home. My bottom lights stopped working after I installed ROG Core and/or updated Windows 10. What do you mean by uninstalling everything? Everything including Windows 10 or just everything Asus-related?