cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix G G531GT side/bottom leds not working

Karellen23
Level 7
Hi!


My laptop's side leds are not turning on.

At first when I bought the laptop it was working, but after changing some keyboard rgb settings in the aura core app, it just stopped working.

Also, I can only see the keyboard in every aura application, and not the sidebars. This was the case the first time I installed Windows too, so it didn't happen after it stopped working.

Contacted Asus support, they said I should reinstall Windows without internet, and install the drivers from the Asus website. I did that multiple times, but the side leds are still not showing up in aura, and are still not working.

After that I read somewhere, that fully draining the battery might solve this issue, tried it, and it didn't work sadly.

Specs are: Windows 10 Pro 64 bit, GTX1650, i7 9750h, 8GB ram, 120hz full hd display

Is anyone else having this problem with these newer laptops?

Could someone help me please?
647 Views
20 REPLIES 20

Replica1
Level 7
Karellen23 wrote:
Hi!


My laptop's side leds are not turning on.

At first when I bought the laptop it was working, but after changing some keyboard rgb settings in the aura core app, it just stopped working.

Also, I can only see the keyboard in every aura application, and not the sidebars. This was the case the first time I installed Windows too, so it didn't happen after it stopped working.

Contacted Asus support, they said I should reinstall Windows without internet, and install the drivers from the Asus website. I did that multiple times, but the side leds are still not showing up in aura, and are still not working.

After that I read somewhere, that fully draining the battery might solve this issue, tried it, and it didn't work sadly.

Specs are: Windows 10 Pro 64 bit, GTX1650, i7 9750h, 8GB ram, 120hz full hd display

Is anyone else having this problem with these newer laptops?

Could someone help me please?


I reset my strix g15 laptop 3 times now and it fixed the bottom RGB for the first 2 times. 3rd time didn't work but I just figured out a solution. Unplug your laptop from power source and Fn + F4 to change the Aura setting a few times and it should turn the bottom lights back on. You can then plug it back in. It was all just because of the buggy Armory Crate and Aura software, not the actual laptops!!!!