Showing results for 
Search instead for 
Did you mean: 

ROG Laptop GL502VS - Type C hub unusable

Level 7
Hey everyone,

At this point I'm completely uncertain whether the issue is hardware, driver or windows caused.
Briefly, I purchased this Type-C Thunderbolt 3 compatible Hub for my GL502VS, to simply connect my USB peripherals and dongles through it. I didn't want to go overboard with the expenses, this is why I chose this HUB.

The Hub connects to the Laptop just all right, Device Manager shows the Generic USB Hub and Generic SuperSpeed USB Hub driver instances activated. The issue is that any connected device functions dodgy, constantly freezing or even completely losing power.
I unfortunately have no possibility to test the HUB with other laptops/PCs, I however checked with a phone with a Type-C port, both my keyboard and mouse worked flawlessly there.

Please let me know whether the Type-C port is faulty on the GL502VS, or if there might be incompatible driver based issues, which interfere.

Thanks, Cheers!

Level 7
I just reinstalled my Windows 10 system. Thought clean drivers and registry entries, with all clean updates would somewhat solve the issue, but it persists. The device still got recognized as Generic USB Hub and Generic SuperSpeed USB Hub as expected and stated in the quickstart guide.
If anyone is aware of additional settings needed to be configured, please reply

Sounds like one of the devices is drawing too much power and this is an unpowered hub. Are you using anything other than a mouse and keyboard?
A bus station is where a bus stops. A train station is where a train stops. On my desk, I have a work station…

Level 7
Nope. The issue persists with only the mouse being plugged in through the hub. Strange, because with a TypeC OTG converter the mouse worked flawlessly.
It may be worth mentioning, that the laptop was RMA'd with issues with the original mobo, so they upgraded it with the revision board and a 230W adapter, so the battery wouldn't discharge under heavy gaming.
Haven't checked the mobo out, so I'm not sure whether this would eventually be an underpowering hardware issue, or the hub would simply be incompatible.

Ever find a solution? My type c is the only active usb remaining. I got a powered hub hooked to it. I’m unable to stream now because all of a sudden all Of my peripherals no longer work. I’ve also done a clean install and with no fix and I used a pretty useful drive updater that identified several drivers that were unstable. still not fixed.

Level 7
No solution. Unfortunately the C port supports no hub, at least by my experience, both with generic Chinese and branded hubs.
I found that with a single USB C -> USB A adapter it might just support a single peripheral, but nothing more. Seems like it's a design flaw with gl502 series motherboards with underperforming C port, and that's it.
I advise you clean your MoBo thoroughly, see if you can get the USB A ports back working, and get some cheap USB A hub.