Showing results for 
Search instead for 
Did you mean: 

ROG GL553VE Audio completely stopped working

Level 7
I looked everywhere on the internet and tried pretty much all suggested solutions for similar problems, but my problem seems to be different.

It all began after I reinstalled Windows (using Reset feature in windows 10).
However, during the installation process I had Cortana talking to me just fine (audio was working), but after the install (I'm guessing after automatic driver update), it stopped working.

1. In my notification area, the audio icon has a red X (not just the muted x, but really a RED x).
2. In the device manager there is a warning icon on the High Definition Audio Controller, and in the status it says : This device cannot start. (Code 10)
3. Evidently there is no sound coming out from anywhere...

I have tried with many different realtek drivers, from the Asus site under the right product, as well as from the realtek site, and from other links on different forums that say they are for the Windows 10 Fall update,...

Tried uninstalling the drivers from Add Or Remove Programs...

Tried running a ccleaner and fix all registry issues many times over until none left...

Also to be noted that the audio does NOT work on Linux either, but I did not try to install any new driver there yet, and I don't know if the audio on this laptop ever worked on linux...
I have a Linux Mint in Multiboot...
Since then I also tried another Live Linux to see if it worked, and it didn't either.

It is also possible that it is the actual Linux installation that broke the audio on Windows (not sure how, but I found a thread here that says that just booting a live linux can suddenly fix the audio on windows for some reason but it would be the other way around in my case).

Also, it is possible that the issue is caused by settings I made in the BIOS so that I can install Linux, which is simply Disabling Secure BOOT and CSM, but since then I tried setting it back as it was and the issue is still there, I don't think I forgot anything, there is not much I can change in that bios !

Again, audio WAS working BEFORE AND DURING the windows installation, but I do not remember testing anything afterwards, I immediately installed Linux in Multiboot, worked fine but no audio there (did not notice at first), then went back to windows to test if the windows boot was still OK, that worked fine, so started to test stuff and that's when I noticed that there was NO AUDIO, with the symptoms listed in the beginning of this post.

The computer is a ASUS ROG GL553VE-DS74 Gaming laptop.

Oh and I also tried to update the BIOS firmware and it did not solve the issue (actually its the first thing I tried right after noticing the issue).

There is one thing that I saw in the forums that I did not try and it's dismantling the laptop, unplugging the battery, pressing the power button for 30 seconds, in hope that it clears all the capacitors and maybe "fix" the audio... Will try that in last resort..
I could also try to reinstall windows, see if I can still hear Cortana speak during the install process, that would confirm if its a hardware issue (or possibly the aformentioned bios settings I made).

I would prefer not reinstalling windows but I will do it in the very last resort if I get no solution, since that would also mean that I must reinstall everything else as well as the linux bootloader.

However I am beginning to think that it's a Hardware issue, but it seams a little weird that it happened the same day of the windows installation...

I hope I put enough details here...
Thanks for your help !

I installed a Live Windows 10 on an external USB hard drive so see if that one would work, and the audio worked there !
I concluded it's not a hardware issue, it has to be software...
So, I did all the updates on that external windows 10 to see if that was what caused the issue, but the audio was still working...
I then restarted back to the original windows 10, and for some reason it started to work again...

I guess that the fact of loading a new windows on an external drive and making the audio work there, woke up the sound card in some manner and made the audio work on the previous windows install...

Any thoughts on that ?

The issue happened again after going back to linux, but there is a workaround.

Basically switching between Linux and Windows was causing the issue.
I was able to get the audio working in both linux and windows simply by not Restarting between them but rather shutting down and starting again.
However if the problem happened again (restarted to linux or the other way around), it takes lots of playing with restart/shutdown+start until it will finally decides to work again. But I noticed that unplugging the power and doing a complete shut down and startup solves it most of the times.
Tried disabling the Fast Startup feature in windows but that does not fix the problem at all, it seems like it's a uncleared memory or something like that when you restart, but if you always shutdown completely when switching OS in a multiboot system it will not cause the issue.

If anyone has a better solution, feel free to tell me, otherwise I hope this simple workaround helps anyone who has the same problem in the future.

Level 7
Hey! I'm having exactly the same issue, the X on audio in windows with "No audio output device is installed" and ubuntu 16.04 worked, but now it does not work anymore, even sometimes when that happened in linux if i reboot the laptop it worked, but now it seems to not be working anymore, neither in my windows.

How did you fix it?

Have you found any better solution?

Please let me know, I miss my sound very much T.T

Asus GL553VE - Ubuntu 16.04

Level 7
Unfortunately, the solution is still the Update #2.
Simply dont restart between the two OS. You need to do full shutdown, power off, and then power on again.

kzaurckichz wrote:
Unfortunately, the solution is still the Update #2.
Simply dont restart between the two OS. You need to do full shutdown, power off, and then power on again.

Yes, it is incredible, why we dont have a fixed for this already oh my god... Literally sometimes I have to reboot 3 times in order to get my sound back.. this is so annoying!:mad:

thank you very much thou, please if you found a fix or something let me know 🙂