cancel
Showing results for 
Search instead for 
Did you mean: 

ROG GL503V - Invalid password in BIOS

Rtxx47
Level 7
Hi everybody.
I come here because I can't find any other solution on my problem...
I just bought the rog GL503V and to secure it, I put an admin password on my bios (with uppercase and numbers).
Now, I can't log into the bios anymore because it tells me "Invalid password".
OK, maybe I'm dumb and I failed to write correctly my password.
So I tried the rescue password with the alt-r thing.
I set my BIOS to 01/02/2002 and use recovery password ALAA4ABA.
Didn't work either.
I'm French and I got an azerty layout.
I tried to put my password with qwerty layout but it didn't work... I tried so much things :mad:.
Asus customer service online said that the only thing I can do is to send it to them at my own because it's not in the warranty... Come on, it's not in warranty? They sell me something not working and I must pay to repair their mistake?

So I'm here to find a better solution with you guys, any idea?

Thank in advance 🙂
2,027 Views
0 REPLIES 0