Showing results for 
Search instead for 
Did you mean: 

ROG gaming center not working after Nvidia driver update

Level 7
I've just updated my Nvidia driver to version 382.53 and now several things stooped working:

Here are some examples:
ROG Gaming center - program stooped working and need to close
Heroes of the Storm - Graphics device not available at this time
Masters of Orion - Failed to initialize Direct3D

I've uninstalled and installed the drivers again.
If I run something in youtube and press CTRL+ALT+DEL , on the GPU graphics I can see that the Intel Graphics gard is working, but not the GeForce GTX 1050Ti

Please help! 🙂

Level 13
Download and run DDU into safe mode
This will uninstall the Nvidia drivers and wipe the orphaned files from the system and registry.
Reboot and reinstall 388.00

“Two things are infinite: the universe and human stupidity, I'm not sure about the former” ~ Albert Einstein

After over 6 hours of chat with Nvidia support and a lot of different drivers installations and blue screens, I finally solved 90% of the problem:

1. I updated the bios
2. I updated the wireless network adapter
3. Reinstalled the video driver

This time I didn't got a blue screen and it installed everything but shadowplay.

What does shadowplay do and how can I fix this? Microsoft told me to reinstall directX and then try again, but it didn't work...

Level 7

I'm having the same problem. After updating the nVidia drivers I rebooted, I got the "Republic of Gamers" splash screen and it stuck in there. My GeForce experience automatic updater stopped working several months back and because I bought the topaz video upscaler, their support suggested me to install the newest driver. I have a GeForce 1070 and it's supposed to be compatible with the newest nVidia drive.


@JustinThyme I'm not too computer savvy... what is DDU?


Thanks in advance.