Showing results for 
Search instead for 
Did you mean: 

ROG G531GT Keyboard Framework Version 2.2.3 not Downloading

Level 7
Ever since I tried to update my keyboard framework to 2.1.8 and my keyboard stopped working completely. I didn't want to get it to a service centre as I had too much work to do and couldn't afford to be without a laptop for more than a week. I hoped that they will publish a new update and fix this issue!

A couple of weeks ago a new version came out 2.2.3 but it is still not working. II checked the logs that the installation is producing and got this

Tool Version : 2.2.3
Product Name : G531GT
[Initialize] Start Flash : 20200421000503
[Initialize] GetKBType : 0
[Initialize] UnReg LightingService
[Initialize] Battery Power Level : 100
[Initialize] GetASUSDevice fail
[Initialize] GetITEDevice

So somehow it is stopping at this stage GetASUSDevice

Any advice on how to solve this? I am pretty stressed to carry a wireless keyboard everywhere I go...

Level 7
Laptop ASUS ROG G531GT

hello i have the same issue but i receive a message that file not found in the cmd then the update screen pop up and stays open for 2 min then it disappear, i wait like for 5 min because in MyAsus app it show that it still loading when it finish i get an error.

please if anyone have a solution help us, because i can't change keyboard LED colors and all the FN shortcuts not working and all the buttons next to Rog button including rog are not working (all of this happened after keyboard update i tried a lot of solutions like bios update, armoury crate, asus interface v2, restting the laptop and downloading the older version of bios, uninstalling the keyboard, clean install for armoury crate, asus interface v2)