Showing results for 
Search instead for 
Did you mean: 

ROG button and Aura Core not working properly

Level 7
Hello! I am using GL753VE right now, and recently I've noticed two problems:

1. My ROG button is not working as it should be. It used to open Gaming Center, but now it doesn't. I have Gaming Center installed, so I'm not missing it or anything, I can open it via shortcut in the menu, but I can't open it by pressing the ROG button. The button itself works, but when i'm on my Desktop and I press it - it just selects my most top shortcut, and if i'm in browser - it just takes me to the top of the webpage, so phisically ROG button is working, but not as it was intended to.

2. 2nd issue is with Aura Core. I can adjust jeyboard brightness alright, but I can't change colours. It's only red, always red. It used to work, I had dark blue keyboard once, or even different colours for 4 zones on keyboard, but for the last few months I only used red colour, and now I can't change it.

I tried clean install of Windows 10, formatted all my drivers etc, downloaded all drivers from ASUS webpage, installed ATK (different versions, the most recent one, as well as some older ones), Gaming Center and Aura Core (again, tried different versions), every other driver, but the issue remained.

I don't know what to do, when I check forums or comments under YouTube videos - there are a lot of people with the same issue, but noone knows how to fix this. Any possible solutions? I would be eternally grateful.

P.S. In attachment below am showing you that even if I set green colour in Aura Core - my keyboard is still red, and also I highlighted the ROG button I am talking about, in case someone need clarifying 😄

Level 12
Did you remember to save a copy of your eSupport Folder? After installing Windows s 10 did you run the ASUS Installation Wizard that's within the eSupport Folder. It's very important to run the wizard and install all the drivers and software from the eSupport Folder.

Without running the ASUS Installation Wizard, many of your programs will no longer work.

Unfortunately, I have no source for a copy of your eSupport Folder. You must return your laptop to ASUS repair center to have your storage device reimaged.

Good Luck
G752VSK, G75VW-3D, G51J, G1S
Homebuilt Windows Server