cancel
Showing results for 
Search instead for 
Did you mean: 

Right arrow key on keyboard of ROG Strix Scar 17 stopped working out of nowhere

adkins
Level 7

Laptop is brand new, only a couple months of use. Took great care of it, no spills, no dust, no jamming of the keys. I updated the drivers, uninstalled them and restarted the laptop so it automatically resets & reinstalls them. I updated the BIOS and windows. I ran the troubleshooter. Still, nothing works and it's only ONE key.

Saturday as I was playing Maplestory, which uses the arrow keys, I noticed the right key lagging. I thought nothing of it. Then yesterday it worked but wouldn't for a few seconds completely, then work again after a few minutes. Now today, the key stopped working at all, not one single response from pressing it in any way, soft or hard, held simultaneously with other keys or not, its just 100% unresponsive.

Can someone please tell me what's wrong?.... I'm confused as hell.

208 Views
1 REPLY 1

world
Moderator

Hey adkins-- unfortunately, sometimes hardware defects do happen. If you go into the BIOS, are you running into the same issue with the right key? 

 

From what you're saying, it does sound like it's more of a hardware issue rather than software, so if you're also running into the issue when you're in the BIOS, I would recommend contacting support to see how they can fix the key.