cancel
Showing results for 
Search instead for 
Did you mean: 

"Can't connect to this Network"

deeptg
Level 7
Hi,
I bought an Asus G75vw couple days back with windows 8. Everything was working fine except that i couldn't connect to my wireless router. It had a WEP encryption. After I entered the Network Security key, I Kept on getting "Can't connect to this network", troubleshooting didnt help either. Then I updated all drivers from Asus support website and it connected after a restart. I was quite delighted but the next day again i got the "cant connect to this network" message. So I changed my encryption to WPA2-PSK (AES) and even updated the firmware of my router. Still no luck. I have googled around a lot but couldnt find any proper solution.
Please please please help me out with this, Im getting really frustrated 😞
356 Views
47 REPLIES 47

On another note. i got the steelseries siberia headset along with my laptop. But even if i watch any tv show or a movie the surround sound is always on. any idea how do i turn it off to get the normal quality ? i just like using surround while gaming else it gets too noisy 😛

rewben
Level 13
oh that's right! now i am clueless haha!

I'd like to attribute this to Windows 8... It sucks terribly, and I'm currently burning a 7 disc... and before anyone wants to jump in about it, I ran it nearly a month, it wasn't some 3 hour excursion... It just plain sucks in every way...
G75VW-DS73-3D | 670m 3GB | 32GB RAM | 1TB RAID-0 2 x 830 512GB SSD DualBoot | Killer-N 1103 WiFi

Skull6
Level 10
Do you have some other sort of security activated on your wireless router, such as MAC address filtering? (If not, you may have some freeloading neighbors taking up the remaining DHCP slots also.)
"If it moves, salute it. If it doesn't move, pick it up. & if you can't pick it up...paint it RED & BLACK !!"
G75VW-BBK5 {stock}

............ Macrium Reflect ..................Full G55VW/G75VW model list!

I'm back setup like a like on 7... Even with a premier wireless card, my WiFi was running like crap... High ping, home page would take a second to load, and as time went by, the link speed to my router would slowly decrease... Terrible OS, they better put out Service Pack to remedy how terrible it is... Now I can enjoy my 105 internet again...

Folks, I think it's safe to stop troubleshooting his issue... His network is fine... His computer however, happens to be running Windows 8...
G75VW-DS73-3D | 670m 3GB | 32GB RAM | 1TB RAID-0 2 x 830 512GB SSD DualBoot | Killer-N 1103 WiFi

Got my laptop back. It connects fine on all of the service center's wireless networks. and some hotspots in public places. cant connect to my home router though. I guess its just windows 8. 😞 so im guessing ill have to wait till official update comes out. 😞

since i got win8 preinstalled, if i buy a win7 kit and install it will it void my warranty?

deeptg wrote:
Got my laptop back. It connects fine on all of the service center's wireless networks. and some hotspots in public places. cant connect to my home router though. I guess its just windows 8. 😞 so im guessing ill have to wait till official update comes out. 😞

since i got win8 preinstalled, if i buy a win7 kit and install it will it void my warranty?


Warranty will be fine... and according to this article if you have another Windows 7 machine, you can use it's product code... pg 2

http://www.pcworld.com/article/2015107/downgrading-from-windows-8-to-7-what-you-need-to-know.html

Of course there are other methods of install as well... I have downgraded back to 7, and am very glad I did...
G75VW-DS73-3D | 670m 3GB | 32GB RAM | 1TB RAID-0 2 x 830 512GB SSD DualBoot | Killer-N 1103 WiFi

Same problem here 😕 . Im so sad that asus had just lost one of their loyal buyers. After the unsolvable sound issue , screen issue , and now a wifi issue , I just think that the G75 was out too early and asusdo nothing to solve it 😕

Im also unable to connect to any WPA2-PEAP networks