cancel
Showing results for 
Search instead for 
Did you mean: 

No sound transferring to T.V via HDMI on GL503VM

Tashfinz
Level 7
As the titles states...I have so far uninstalled and reinstalled my sound drivers as well as manually downloading the update through Asus' website. I've checked device manager and the t.v is acknowledged however the sound isn't. I've tried different HDMI cables and updating my sound drivers and still nothing. Does anyone have any solutions?

My laptop is the ASUS ROG Strix GL503VM-FY022T
3,066 Views
8 REPLIES 8

Peneoark
Level 9
Did you set HDMI as default sound?

Peneoark wrote:
Did you set HDMI as default sound?


That's the thing it's not showing up in the playback option in Sound options. I also enabled it to show disabled playback devices as well and the t.v speakers didn't show.

Tashfinz wrote:
That's the thing it's not showing up in the playback option in Sound options. I also enabled it to show disabled playback devices as well and the t.v speakers didn't show.


Are you seeing Digital Output as an available sound device? If so, try selecting that.

Peneoark wrote:
Are you seeing Digital Output as an available sound device? If so, try selecting that.


72862

Nope

Can you test it on another TV, or possibly test with another HDMI cable? Also, can you check your TV settings and make sure that the audio is set to HDMI? You can also try defaulting the TV settings.

This is really strange.

Peneoark wrote:
Can you test it on another TV, or possibly test with another HDMI cable? Also, can you check your TV settings and make sure that the audio is set to HDMI? You can also try defaulting the TV settings.

This is really strange.


Still no change, tried another tv and tried another HDMI

Peneoark wrote:
Can you test it on another TV, or possibly test with another HDMI cable? Also, can you check your TV settings and make sure that the audio is set to HDMI? You can also try defaulting the TV settings.

This is really strange.


72864

I'm at a loss here and nothing more I can test without getting my hands on it. Hopefully you will find a solution. Good luck.