Showing results for 
Search instead for 
Did you mean: 

[LINUX] Fan speed issue on GL753VE - nvidia, bumblebee, bbswitch, ACPI

Level 7
Currently there exists a major issue on GL753VE laptop (and possibly other similar Asus products) when using Linux, that causes fan speed to go out of control and be stuck at 100% until the system is powered off (reboot is not enough). This severely hinders the usability of this product.

The problem begins when user wants to use the discrete GPU (nvidia gtx 1050Ti in this case). The user has to go through the optimus mechanism, because there is no "discrete-only" switch in Bios to permanently switch to using the nvidia GPU for everything.

On Linux, the usual way to use an optimus card is via bumblebee [0]. Bumblebee relies on bbswitch [1] to power the discrete GPU on and off.

On Asus GL753VE, powering the discrete GPU *on* works fine, and the card itself works well (accelerated rendering performs well). However, when powering the card *off* is when the strange thing happens. About 10 seconds after bbswitch issues the off command, the system fan (there is only one fan on this laptop) starts to work at 100% speed (*very, very* loud) and there is no way whatsoever to turn it off or make it spin down.

The issue has been discussed many times and has reported to the relevant projects [2] [3] [4] [5], but apparently this is not so easy to fix and the underlying cause is in the Asus DSDT (ACPI) tables [6].

I have Bios version 302 which I beleive is currently the up-to-date version.

This laptop is my first Asus model, I have been a lifetime Dell user. I have been struggling to solve this for nearly two months now. It would be nice if Asus assisted somehow in solving this issue.

Looking forward to your response.


EDIT 2019-11-30: SOLVED

Level 9
It seems that at least get some help with linux from ASUS assistants is very low.

Level 7
hi, I have GL753VD, it's not the same, but almost. Current BIOS version on the Hungarian site: 304. It DIFFERS from language to language! Worth checking other country's sites because of the lazy update. Slight chances but maybe they addressed this issue....

Have you tried running your system with Prime instead of bumblebee? Which nvidia driver you using? Which Linux? which kernel? So many questions! Please post results of inxi -Fxz


I have the same issue. For systems like ours (cannot disable the intel graphics chip from bios) bumblebee is the only way to have proper access to the NVIDIA GPU.

The issue as explained by 01001 has been discussed on all levels (Bumblebee project, NVIDIA forums and even on 's blog.
The only possible solution for us now is that somebody from Asus to take a look at the provided discussions and figure out a possible solution or to point us into the right direction.

Adding one more link:

Running Fedora 27
inxi output:

System: Host: localhost.localdomain Kernel: 4.14.11-300.fc27.x86_64 x86_64 bits: 64 gcc: 7.2.1
Desktop: KDE Plasma 5.11.4 (Qt 5.9.2) Distro: Fedora release 27 (Twenty Seven)
Machine: Device: laptop System: ASUSTeK product: GL753VD v: 1.0 serial: N/A
Mobo: ASUSTeK model: GL753VD v: 1.0 serial: N/A
UEFI: American Megatrends v: GL753VD.303 date: 04/28/2017
Battery BAT0: charge: 36.4 Wh 96.3% condition: 37.8/48.2 Wh (78%) model: Simplo SDI ICR18650 status: N/A
CPU: Quad core Intel Core i7-7700HQ (-MT-MCP-) arch: Skylake rev.9 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464
clock speeds: max: 3800 MHz 1: 2800 MHz 2: 2800 MHz 3: 2800 MHz 4: 2800 MHz 5: 2800 MHz 6: 2800 MHz
7: 2800 MHz 8: 2800 MHz
Graphics: Card-1: Intel Device 591b bus-ID: 00:02.0
Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0
Display Server: 119.5 drivers: modesetting (unloaded: fbdev,vesa) Resolution: 1920x1080@60.02hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2)
version: 4.5 Mesa 17.2.4 Direct Render: Yes
Audio: Card Intel CM238 HD Audio Controller driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.14.11-300.fc27.x86_64
Network: Card-1: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
IF: wlp2s0 state: down mac:
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 100 Mbps duplex: full mac:
Drives: HDD Total Size: 3000.6GB (85.3% used)
ID-1: /dev/sda model: HGST_HTS721010A9 size: 1000.2GB temp: 33C
ID-2: USB /dev/sdb model: Elements_1048 size: 2000.4GB temp: 0C
Partition: ID-1: / size: 184G used: 17G (10%) fs: ext4 dev: /dev/dm-1
ID-2: /boot size: 465M used: 167M (39%) fs: ext4 dev: /dev/sda2
ID-3: /home size: 682G used: 605G (94%) fs: ext4 dev: /dev/dm-6
ID-4: /var size: 37G used: 19G (53%) fs: ext4 dev: /dev/dm-5
ID-5: swap-1 size: 16.00GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 54.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 311 Uptime: 2:10 Memory: 2869.9/15924.3MB Init: systemd runlevel: 5 Gcc sys: 7.2.1
Client: Shell (bash 4.4.121) inxi: 2.3.53

EDIT: maybe related issues:

I have had the same issue and after a long time trying everything I could find on the Internet, the only thing that worked for me was reflashing the Intel management engine chip.

In this regard, my first tentative was to disable the chipset with me_cleaner:

I extracted the firmare from the chip and after saving a copy of it I followed the procedure described on the wiki above.
Unfortunately this didn't work well, and even though the laptop was able to boot, it crashed as soon as the nvidia card got active.

After that I flashed back the original firmware and magically the fan issue was fixed for ~15 days. Then the fan got crazy again so I extracted again the firmware from the chip. To my surprise this version was different from the first backup that I had, very suspicious really.

I flashed back the first backup and up to now the fan is stable, if this thing will happen again I probably will solder wires to the chip to expose an external connector that will allow me to flash the chip back without the need to open the case of the laptop.

My whole nightmare is described in this post:

Good luck!

SpookyWatcher wrote:
Have you tried running your system with Prime instead of bumblebee? Which nvidia driver you using? Which Linux? which kernel? So many questions! Please post results of inxi -Fxz


I have since found a way to run everything through the nvidia gpu (following these instructions - I assume this is what you mean by "prime").
This way results in fully accelerated (by a fast GPU) graphics and no 100% noise from fan.
This way however results in larger battery power consumption than is needed.

Updating bios to 306 did not change anything.

I am using nvidia drivers 384.98 with kernel 4.14.
The linux distribution is Debian Unstable.

I don't have inxi installed.

Still waiting for a technical solution provided by AsusTek Computer Inc representative on this serious issue.

Updating to BIOS 307 changed nothing. I strongly suspect that this is an ACPI (DSDT) issue in Asus BIOS firmware.

The problem appears after this line shows up in kernel log (dmesg):

[ 136.356192] pci 0000:01:00.0: Refused to change power state, currently in D0

Is there a place where I can file a bug or support ticket so that someone on ASUS side can check this?

Level 7
I have found a solution to this problem and documented it here in case anyone needs it.

The topic can be marked as [SOLVED].