cancel
Showing results for 
Search instead for 
Did you mean: 

Keyboard on GL504 gives wrong inputs

GeoGC
Level 7
Because it's a bit difficult to understand, I provide 3 small video clips.

https://www.youtube.com/shorts/MfhRj7eyo9g

https://www.youtube.com/shorts/-yeBL1li9Tg

https://www.youtube.com/shorts/4RqROA1qHFE


For the past 2 days, my keyboard at my laptop is acting weird. It pressed wrong inputs, like 2 at the same time, however they are linked. What I mean with linked?

If I press "a", it will type "aj". If i press "j" it will type "aj".

If i press "q", it will type "qm", same if i press "m", it will type "qm".

Function key will act as fnc+h. And "h" button will do the same.

Tab will act as tab+y and if i press tab button on a notepad, it will input " y" with big gap of space like normal tab does. Most of the buttons work normally however there are like 6-7 that are totally wrong.

Yesterday i had that issue but it got fixed randomly, and today in the morning it was working normally until at night it started the same issues. I uninstalled the keyboard drivers from device manager, it didn't got fixed, then i randomly restarted laptop and it got fixed but after 10mins it started again.

I'm so confused what it could cause this issue and how can specific keybuttons be linked and matched. I even uninstalled Armoury Crate that Asus has in case that was causing it, but nothing changed. I haven't installed anything or download in that 3 days so I'm so confused.

I ran windows on safe boot, same problem. I ran it on Ubuntu via USB stick, same problem.
468 Views
1 REPLY 1

Danielmoro
Level 7

I'm having the exact same issue. I tried more or less the same things. Even cleaned the key caps after removing all of them. It has to be something related to time, be it time since the model is out(have the same one) or some software that came out(even though I always do my updates so I don't get it how it only happened to me now.