cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with new laptop Strix Scar 17 2023 (R9 7945HX, 4080)

hexaae
Level 12

MY ISSUES WITH THIS G733PZ Strix Scar 17 2023 (R9 7945HX, 4080)

Love it but it has many annoying little issues (fully updated with Win Update and MyASUS official app, BIOS 311):

  1. [COMMON] Speaker sounds randomly muted 'till I reboot with no error in Device Manager, no icons with X and no crashes, but speakers simply do not play audio anymore (headphones still work). Only solution a reboot. Totally random in normal desktop usage.

  2. [COMMON] Sometimes randomly after 2 days of sleep and resume, USB-C DisplaPort won't detect anymore the attached (but turned off) monitor when I turn it on. Have to reinsert DisplayPort cable (8K high quality). To be exact it happens after Windows Hibernation. (SOLVED with BIOS 315 ✔️)

  3. [MY UNIT] Loud coil whine with the test from GPU_Caps_Viewer: 3D Demos/Vulkan 2 Tessellation. Tested in real games or other 3D Demos and coil whine is minimal and acceptable though...

  4. [COMMON] Random internal screen (desktop usage) fast-flickerings (0.1sec, very fast almost unnoticeable, mostrly in the upper portion of the screen)... looks like AMD iGPU unstable frequency (?). This seems a well known AMD iGPU issue reported in many forums with previous AMD CPU models. Waiting for AMD Adrenalin driver/BIOS updates hoping for a fix... 🤞🏻

  5. [COMMON] No S3 Standby state in the BIOS!! Forced S0 only (a sort of MS hybrid standby 2.0) with fans quietly active (???). You can check it with powercfg /a from admin Cmd prompt. Microsoft calls it "Modern Standby", which is good only for office workstations, maybe. We need S3 (classic Standby) instead.

  6. [COMMON] Standby set as: after 10 min screen off and after 45 min standby; when I return to the laptop after 1-2 hours I find the keyboard leds on and system freezed including stuck white mouse pointer over a black screen (!?). I've found a workaround from admin prompt simply forcing hibernate after 30 min and setting screen off and standby both after 10 min. It didn't happen anymore.

    Power settings commands (admin):
    powercfg /x  hibernate-timeout-ac 0  (default 0, AC is for PSU mode)
    powercfg /x  hibernate-timeout-dc 60 (default 60 min = 3600 sec, DC is for battery mode)
    powercfg HIBERNATE ON (force-enable Hibernation if not present)
    and
    powercfg /q (to show current idle settings)
    Microsoft link on how to disable Modern Standby, if you want to: https://learn.microsoft.com/en-us/windows/iot-core/learn-about-hardware/wakeontouch
    Recommended: enable hibernate, something like 45mins AC and 20mins DC, you can keep Modern Standby set after 30 and 10mins. This will workaround unresponsive screen or keyboard after a long time if you rely solely on Modern Standby (probably drivers are still not good enough).

  7. [COMMON] BSOD or other issues connecting an autopowered storage device to the rear USB-C ports. I tried 3 different external enclosures with different controller chipset (ViaLab USB\VID_2109&PID_0716, Realtek USB\VID_0BDA&PID_9210, ASMedia USB\VID_174C&PID_235C) with a 2TB disk inside. They all caused strange slowdowns just opening directories and random black screen or direct BSOD (ViaLab in particular). In other cases they just disconnect frequently (unstable). Same devices connected to the lateral USB-A ports or to another PC work perfectly. Probably BIOS issues still present with 315.
    NEWS: there's an (untested) hotfix for ASMedia USB ports on the official site in the download page!

  8. [COMMON] RANDOM REBOOTS 🧨 MAJOR ISSUE, in particular while using the machine at desktop through APU/iGPU (especially watching simple YT videos), even after factory reset and no driver updates! Here was a video showing this severe issue: https://1drv.ms/v/s!ApMUGr0cuN39gsMCAwx9_wjnHscEXg?e=DJlN7i 
    👉🏻 NOTE: if you're using "NVidia GPU Only" mode (or Ultimate mode from Armoury Crate) you won't be using the APU at all, so this issue should not be reproducible... Some users reported random reboots also in Ultimate GPU mode (= not using iGPU/APU)!
    👉🏻 NOTE2: users reported that completely uninstalling Armoury Crate (good free replacements tools are Laptop ToolBox or G-Helper) + BIOS 327, solved all their random reboots. Please test and confirm!
    👉🏻 NOTE3: some users reported changing RAM modules fixed instability. Recommended: Kingston Fury KF556S40IBK2 running at 5200MT/s on this laptop.


    It's a powerful machine and many things are good but is also affected by a lot of bugs... hope they are just BIOS or driver issues and will be fixed one day 😞

✍🏻 IMPORTANT: to report issues with Armoury Crate to ASUS support, follow this post (create the log and fill out the form!): https://rog-forum.asus.com/t5/armoury-crate/armoury-crate-v5-7-6-0-amp-v5-7-9-0-aura-creator-v3-7-6-...

--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, 8BitDo Arcade Stick, EasySMX X10 controller, ROG Strix Carry mouse
62,745 Views
655 REPLIES 655

hexaae
Level 12

About point 2:

Just found that when is not working, running HWiNFO64 resumes normal behaviour and the external monitor through USB-C DP1.4 in the laptop wakes up again! Clearly a software driver bug ASUS should fix. Looks like the USB-C video port needs a software wake up trigger after Hibernation!

Repro steps for ASUS to reproduce the issue:

  • set Windows screen mode to single display (external or internal)
  • set G733PZ to "Optimized GPU Mode" (auto switch iGPU<->dGPU)
  • connect external monitor to the USB-C DP1.4 rear port near HDMI (ext screen will turn on and internal will turn off)
  • switch external monitor off (ext screen will turn off and internal laptop display will turn on)
  • put G733PZ in Hibernation or let it go automatically after Sleep+Hibernation for a long time
  • resume G733PZ
  • switch external monitor on. At this point it should turn ext screen on and internal display off, but nothing happens: laptop will ignore connected external monitor turned on (connected through USB-C DP1.4 cable)
  • run a program like HWiNFO64 triggering ports and connected devices, and ext monitor will finally turn on again!

Ext monitor connection after Sleep only will always work fine instead. The problem with "lazy USB-C DP port" will happen only after laptop Hibernation.

NEWS: fixed with BIOS 315 ✔️

--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, 8BitDo Arcade Stick, EasySMX X10 controller, ROG Strix Carry mouse

hexaae
Level 12

New BIOS 315 today solved point 2! No more lazy external screen wake up after Hibernation! 👍 ASUS

--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, 8BitDo Arcade Stick, EasySMX X10 controller, ROG Strix Carry mouse

hexaae
Level 12

VIDEO SETTINGS

Recommended video settings to compensate a bit excessive saturation and too hot temp (yellowish desktop): 

Change screen color settings from AMD Adrenaline: Temp 6500 to 7000; Saturation 100 to 96Change screen color settings from AMD Adrenaline: Temp 6500 to 7000; Saturation 100 to 96

--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, 8BitDo Arcade Stick, EasySMX X10 controller, ROG Strix Carry mouse

Does this change the screen color? I have Strix Scar 17 2023 (R9 7945HX, 4080)

hexaae
Level 12

Seems to support SODIMM Kingston Fury Impact 5600 at 5200 instead of standard ram banks at 4800:

image

--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, 8BitDo Arcade Stick, EasySMX X10 controller, ROG Strix Carry mouse

Have you tried other ram manufactures such as G Skill? 

I was thinking of getting the 4800 low latency 32gb kit, not sure if this latency profiles are available for this laptop.

This could be an option. I've not been into laptops for a while.

Got and latencies are automatically taken bios 316.

after a fresh installed of windows 11 (not the asus version of this windows included with the laptop).

I installed only the things I'll be using, none of the asus tools for fancy stuff (yet) and the laptop is FLYING, 0 slowdowns or stutters. Already installed some of my work software and although is not optimized for AMD it's def functioning considerably better.