cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with my asus rog strix gl702vm touchpad right click - solved?

mconan
Level 7
So the right click on my asus laptop doesn't work each time i restart my computer. If i repair or rollback the driver it works until I restart.
Then it stops working again. My laptop is 3 days old. I have done a reset of windows which fixed the issue for a time, however now it is back.
I spoke with asus who told me they will not replace or refund . 3 days old. pretty unhappy, the representative also told me that they are aware of a firmware updating causing this issue and it is not resolved.

$1500 I spent on a machine that does not have basic functions working, then i am told i am not entitled to a refund. On top of this I bought the laptop on the basis that is has thunderbolt, however the thunderbolt on the machine is 10gpbs not 40. meaning i can not use it for an external graphics card hub.

All in all pretty unhappy about the situation, i regret buying the laptop and wish I had got the msi......

Anyone who can offer a solution to the right click not functioning would be helpful as it seems I am stuck with the laptop despite the fact it doesn't work properly.
$1500 is a large investment for me and to get something that doesn't work properly is upsetting, I am actually wondering the legal reality of giving a customer a faulty product in terms of returns and refunds.
its actuall the 502 version
308 Views
33 REPLIES 33

E-squirrel wrote:
This issue and its resolution are mentioned in the FAQ section of the support page.

https://www.asus.com/us/support/FAQ/1031506/

If you don't want to read it, here are the steps:

1. Open Device Manager
2. Expand Human Interface Devices
3. Right click on Microsoft Input Configuration Device and choose Update Driver
4. Choose to search automatically..
5. Let Windows install the new driver for this device

I have a GL702VM and can confirm that it worked...and is still working after several reboots.


This worked for me. Thanks

Kildarien wrote:
I have the same issue, very frustrating... I'm hoping for a fix soon. Are we sure it's just a firmware/ windows 10 compatibility issue? or a hardware issue that I will have to send it in for a replacement? I am also curious if any of you here the sound of hardware being connected/disconnected every time logging in after a restart? even when I have nothing plugged in to the laptop it makes the sound..It could be related to the touchpad issue possibly.

Okay so I just figured out that it was my Logitech mouse software that was making the sound on restart

Thanks,
K


This worked for me. Thanks!

jasond767
Level 7
Still no fix.... any suggestion?
Just in case when I turn off fast boot the problem gets worse as the right click stopped working on windows restart or shutdown.
While having fast boot ON right click only doesnt work after windows restart.

ive tried finding different drivers for i2c ive had microsoft input configuration device drivers and asus input configuration device drivers,
the second i opened my laptop the right click didnt work, so going to microsoft generic hid device drivers gave me my right click back.
ive scoured windows.update catalogue searched by device -vendor id, looked at other devices related to i2c
asus seem to be using either a new i2c ACPI/elan1200 or theyve customized it so other drivers from elan wont work
with fully updated drivers:
scrolling breaks and the pointer breaks up and stutters and resets for a few minutes right click doesnt work on reboots, asus need to own upto this and bring an updated bios.

with microsoft driver: still breaks up and tpuch input is un responsive

this device had the same issue and was fixed with a bios update: Acer Aspire V5-591G
https://community.acer.com/t5/Windows-10/touchpad-stopped-working-after-windows-10/td-p/372205

it also has an elan i2c touchpad ACPI/elan1000

they simply added an option in the bios to disable advanced touchpad features

if this isn't sorted soon ill be sending my laptop back