cancel
Showing results for 
Search instead for 
Did you mean: 

Is your ELAN1200 touchpad not working on Linux? :D

taitair
Level 7
You will need the latest stable kernel.

Here's some instructions on how to get the latest kernel for Ubuntu 18.04. The instructions transfer to any Debian-based distro and might transfer to other distros like fedora, RHEL or etc. As far as I can tell this was tested and works with Ubuntu 18.04.

- get the prerequisits: sudo apt install git fakeroot build-essential ncurses-dev xz-utils libssl-dev bc
- Download the source for the latest stable kernel on kernel.org.
- Extract the tar.xz file in a folder of your choosing with
tar -xJf
.
- Go in the extracted folder and copy your current configuration which is in /boot/ with
cp /boot/config-$(uname -r) ./.config
(Might need to be root)
- run
make menuconfig
, save the config to .config and exit.
- run
make -j 
(if you forget -j it will take for ever)
- run
make modules_install -j 

- run
make install -j 


If everything goes correctly, initramfs and grub should get updated automatically, if not:

- run
update-initramfs -c -k 

- run
update-grub

The new kernel was now installed correctly. Make sure i2c-hid is not blacklisted, no ACPI parameters are supplied to GRUB, reboot and enjoy your touchpad.

Hope this helps someone!
21,419 Views
7 REPLIES 7

helix400
Level 7
This works?

I was running a Linux dual boot. I had some big touchpad issues in Ubuntu 18.04. The mouse would work for about 5-10 seconds and then just stop dead. All sorts of tricks didn't bring it back. Worse, rebooting didn't fix the problem, and the trackpad would stay dead in Windows. Only if I did a full off/on computer restart and booted only into Windows would the problem go away. Also, Ubuntu 16 seemed unaffected by the problem.

Yes, kernel 4.15 which comes with Ubuntu 18.04 does not support the ELAN1200 touchpad.

Kernel 4.17.2 which I tested works, though has a few bugs.

You need to
modprobe -r hid-multitouch && modprobe hid-multitouch
when the touchpad disconnects.
I am currently working with the Ubuntu community to get this to work:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1777679
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1778087

I have also made a script to reset the driver easier when it gets disconnected. Email me at alistair.sutter@orange.fr if you want my script. (It is short, ~10 lines and you can check the code for any "malicious code", and I will help you install it/get it to work).

All this because ASUS had to cheap out on the touchpad for our laptops. I am done buying ASUS and so should you. I put my money where my mouth is. ASUS has let down the entire linux community. And even though they said, Linux is unsupported, the touchpad isn't even well supported on Windows (you will notice it still jumps and acts erratically).

They don't support linux, but can't even support Windows properly, what a joke!

Hello

i have the same problem on an ASUS GL703GE that has the same or a similar touchpad.

I can not get it working, on my Ubuntu 18.04 i treid with Kernel 4.17.0 and 4.18.0.999 from the Ubuntu website but it does not seem to work. Any help would be helpful and i could also install teamviewer or something like that if nobody has a GL703GE to test. i also modprobed hid-multitouch but it does not work.

With kind regards
Marc Landolt

Have you tried the official kernels from kernel.org at all?

Those seemed to work better for me than the modified Ubuntu kernels on the Ubuntu site.

Let me know, I can help you get it to work.

I installed now the 4.17.8 Kernel and modules from kernel.org and the laptop boots up properly but the touchpad still does not work...

There is a Solution now for the GL703GE Touchpad, a great guy at kenel.org fixed it:

On Ubuntu 18.04 you must download Kernel 4.18.rc6 form Kernel.org, apply 2 Patches and compile it.

Comment 68 https://bugzilla.kernel.org/show_bug.cgi?id=199911#c68.

Unfortunately still the same disconnection problems like on GE503VS.

Hi everyone,

Been a while. The problem was fixed for me in kernel 5.2.5. But from what I understand the problem was then upstreamed to 5.3.0 and is still being upstreamed in the latest kernels.
If you're still having this problem I suggest:

  • Installing the latest libinput from freedesktop.org
  • Installing kernel 5.2.5 from Ubuntu's mainline builds.




Hope it helps someone,
Best regards.