cancel
Showing results for 
Search instead for 
Did you mean: 

Installed SSD not showing up at times - HELP?

k1eddy
Level 7

Hello everyone. I bought a ROG Strix G18 early this year and it has been functioning great, my only problem is that it came only with a pre-installed 1tb drive as it's main drive. I decided to install an old 2tb SSD on the 2nd m.2 slot and it worked well. I figured I needed more space (for gaming and downloads), so I decided to buy a 4tb SSD off Amazon (Transcend 4TB M.2 2280 PCIe Gen4x4 NCMe SSD - TS4TMTE250S). It worked well at first but I noticed that it does not show up under This PC at times (only the original 1tb Drive C showed up) and I need to restart/shut down my laptop a number of times for it to appear (I need to lift my laptop up, remove the power cable, etc.). Most of my programs are installed on this drive since as I mentioned, the main drive was only 1tb. I tested my old 2tb SSD again today and it showed up immediately so decided to switch up SSDs again and my 4tb SSD appeared for 3 straight restarts and upon attaching the laptop to the power cable, decided to turn it on again, the damned 4tb SSD was again nowhere to be seen and totally undetectable. I already got in Disk Management and rescanned drives, refreshed, etc. to no avail. Can anyone help me with this matter? Thanks.

127 Views
0 REPLIES 0