cancel
Showing results for 
Search instead for 
Did you mean: 

[HELP] Strix SCAR 18 Ejectable RTX 4090 GPU

rihan
Level 8

Hi I would like to know if someone is experiencing an RTX 4090 gpu treated as an ejectable like flashdrive in Scar 18 or 16 (see screenshot)? I would like to know if this is normal or not? I already uninstalled the graphics drivers and reinstall the one that is found in the asus driver site and I also tried to uninstall the hardware in the device manager and then reinstall but ejectable gpu is still there. I also load the defaults in the bios and saved but the ejectable gpu is still there. Any thoughts? Thanks.

rihan_0-1688020251647.png

 

 

651 Views
7 REPLIES 7

rihan
Level 8

Additional notes, the laptop is fully updated with the latest drivers and bios. 

hi

After a clean install of windows ? 😉

Download and install "ASUS Vbios Flash tool" or « ASUS Precision Touchpad driver ». You can find it on your drivers Asus page.

Restart.

It's fix. 

have a nice day. 

 

TUF GAMING F17 (2022) FX707ZM
I7 12700H / RTX 3060 / 32 Go

Asus ROG STRIX G18 (G814JV). I have the same problem. There is no "ASUS Vbios Flash tool" on my laptop's driver download page.

Try to install "ASUS Precision Touchpad driver" 

I don't know what the connection is with GPU Nvidia, but IT fixed it for me following a clean new installation of Windows.

Good luck.

TUF GAMING F17 (2022) FX707ZM
I7 12700H / RTX 3060 / 32 Go

This is really very strange, it’s not clear what the connection is, but after installing the “ASUS Precision Touchpad driver” the video card eject icon really disappeared. Thanks for your help, all the best.

This clearly is some kind of bug, I don't see the connection between a precision touchpad driver and 4090 eject icon 

Btw, one time I accidentally pressed eject, because I wanted to eject my USB pendrive, the screen automatically shuts down and nothing can be done

The laptops needs to be shutdown - pressing the on/off button for a few seconds - after turning it on again, everything is back to normal 

But yeah Asus should fix this without the need to install some precision touch driver

Hi @kikimahe 

Thanks for sharing this solution. Upon installing the Precision Touchpad driver the Ejectable RTX 4090 GPU was gone.