Showing results for 
Search instead for 
Did you mean: 

Gl704gw Won't power on

Level 7
I recently attempted to repaste the stock thermal paste to try and lower some thermal temps when gaming. When I went to disconnect the power connector from the battery to the board, when the metal retainer (Green in pic) popped off the connector, and landed just above (Blue in pic), ontop of some soldered points. I was able to reattach it to the connector and then proceded with the repasting. After all was done, and battery reconnected, I went to power on laptop and It would not power on. Whether on battery or plugged it, it doesn't power on and no lights indicate ac plug is attached. Attempted some trouble shooting by switching ram to a known good one, removing 2.5" hdd, and trying to run laptop just on ac power with battery disconnected. Nothing seems to help. At this point, I've been able to get the ac light to come on with 2.5" hdd and battery disconnected, with ram in place. However once the power button is pressed, the rgb lights will come on for a second then go out and still does not power on. Is it possible something shorted out by the retainer contacting some of those solder points? What other things can I try to troubleshoot? Or am I out of luck and probably fried the Mobo? It's running windows 10 on bios 308, 2tb hdd, 512 ssd nvme, and 32gb ram. Please, any help is appreciated. Thanks.

Welcome to the forums and wish it could be under better circumstances, but hopefully somebody has a solution.

Anyway, unless you used conductive thermal paste that went somewhere it shouldn't have, seems like the system should still be working since it's not obvious you did anything seriously wrong.
You may have tried it already, but you may want to follow the same disassembly steps as before just to make sure nothing was forgotten or done incorrectly during reassembly last time.
Make sure there aren't any missing screws and the correct screws were used in the correctly locations.
You may want to try to gently rock the notebook back and forth just to make sure you don't hear any loose screws or objects inside the system.
Check any cables you unplugged last time and try unplugging and reinstalling them to make sure they are okay.
It's really the flat ribbon cables if you had to unplug any of them rather than the cables like the battery connector that concerns me more.

May not help, but it's easy to try, so suggest just holding the power button for about 20-30 seconds with the AC adapter unplugged just to see if that 'resets' anything before you plug back the adapter to power it on.

Feel free to let us know if it's still not working and request more ideas from others.