cancel
Showing results for 
Search instead for 
Did you mean: 

GL703GS keyboard dead on Shutdown/Hibernation, apparently after some Windows updates

hexaae
Level 12
The issue:
all of a sudden on 16 March 2020 I noticed that when I resume from Hibernation, the keyboard leds won't turn on, but keyboard still works and I can restore leds with ROG AURA Core... but at this point with led off after Hibernation, if I reboot the keyboard will totally stop working except Mousepad and Power button (it also keeps led turned off)! This persists even at BIOS and on next reboots!! Keyboard not working except mousepad and power button all the time.
To restore leds and keyboard I have to: Shutdown, unplug PSU, and press multiple times Power button...

I'm afraid it is a Windows 10 1909 issue after recent updates + ASUS software conflict of some kind. I tried to uninstall recent ones (got updates on 7, 11, 14 of March) but didn't help. Have no idea why this happened and hope someone has had similar issues and has a solution because ATM I can't use Sleep and Hibernation reliably anymore 😞

I tried also to disable ROG Armoury II (I use for Carry Strix mouse) and ledcontrolservice3 but didn't help:


These are my (left) Win updates:


To recap:
Hibernation or Shutdown now make keyboard leds turn off "forever" even with next reboots. When leds are off only mousepad and power button do work.
To wake up keyboard (and its led, have no idea why they seem connected now) at this point I have to:
- enter Hibernation or Shutdown with power cable
- unplug cable and press Power button to resume laptop using battery: this will wake up leds and keyboard will work fine.

No idea why... 😞

Gaming Laptop ASUS GL703GS (BIOS 310)
CPU i7-8750H (iGPU unavailable)
GTX 1070 8GB (non-Max-Q, 10DE 1BE1 - 1043 1011, GP104 A1, vbios 86.04.7c.00.24, Samsung VRAM)
Windows 10 Pro 1909
Desktop res: 1080p (1920x1080)
Screen: 144Hz + g-sync AUO B173HAN03.2 [AUO329D]
Audio: Realtek HD Audio (ALC295 chipset)
Hard disks: NVMe Samsung, SSD Crucial
USB Blu-Ray 4K drive: Archgon Star MD-8102P-U3YC-UHDB (Pioneer BDR-UD04)
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse
983 Views
1 ACCEPTED SOLUTION

Accepted Solutions

hexaae
Level 12

RESTORE DEAD KEYBOARD AND LEDS (ASUS GL703GS)
Two years later it started to happen again since the other day, right after hibernation or shutdown (no problem to resume from sleep)!!
Keyboard dead (no key works even from BIOS) and led is turned off, even power button is not backlit when this happens.

EDIT: used https://dlcdnets.asus.com/pub/ASUS/GamingNB/GM501GS/KBFWUpdateTool_v1.0.5_forSupportSite.zip

Just ran it from Windows 10 ("This tool will update your keyboard fw if needed... blah blah"), pressed the (only available) "Update" button... a progress bar started and after less then a minute the keyboard leds turned on during process and keys worked again! Didn't even have to reboot.
Checked hibernation and... it WORKS FINE AGAIN after resume! Lifesaver tool!
Everything runs fine, including numpad and caps-lock key led.

Let's just hope it works when it does again (in the next 2 years?) and will not complain that the FW is simply up to date at that time... (Yes, the tool worked fine after it happened again!)

--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

View solution in original post

22 REPLIES 22

hexaae
Level 12
Already resetted BIOS to Default and Saved but didn't work...
I'm still wondering if this could be a bug after some Windows 10 update in-between 11-16 of March and already tried to uninstall them (except KB4540673 which can't be removed).
Do you think a Win update bug could f*** up some BIOS default settings?
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

davemon50
Level 11
Windows update killed my ATK package, I had to reinstall it. I didn't have the same issues you did, but reinstalling ATK package (as Administrator) resolved any new conflicts for me after Windows updates. Perhaps it will for you if you find it on your downloads page.
Davemon50

hexaae
Level 12
Thank you. Unfortunately didn't solve the issue... I've also noticed Windows 10 today wanted me to install ASUS Numpad driver but it fails with Code 19
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

hexaae
Level 12
Interesting... another user with similar issue (which seems to suggest a Windows update VS ASUS conflict as I always suspected?): https://rog.asus.com/forum/showthread.php?117130-GL703VM-Keyboard-Stopped-Working&p=800425#post80042...
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

hexaae
Level 12
Feedback from other users with GL703GS...?
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

hexaae
Level 12
DEAD KEYBOARD AFTER HIBERNATE OR SHUTDOWN (latest news...)


Gaming Laptop ASUS GL703GS (BIOS 310)
CPU i7-8750H (iGPU unavailable)
GTX 1070 8GB (non-Max-Q, 10DE 1BE1 - 1043 1011, GP104 A1, vbios 86.04.7c.00.24, Samsung VRAM)
Windows 10 Pro 1909
Desktop res: 1080p (1920x1080)
Screen: 144Hz + g-sync AUO B173HAN03.2 [AUO329D]
Audio: Realtek HD Audio (ALC295 chipset)
Hard disks: NVMe Samsung, SSD Crucial
USB Blu-Ray 4K drive: Archgon Star MD-8102P-U3YC-UHDB (Pioneer BDR-UD04)


Strange issue since 16 of March.
After Shutdown or Hibernation, on next resume, keyboard is dead and disappears even from Device Manager. Also leds stay off. At this point to resume keyboard I have to:


  • Shutdown/Hibernate again
  • unplug power cord
  • resume PC with Power button (using battery mode)

This will make keyboard (+leds) resume as usual, 'til next Hibernation or Shutdown. No problem with Sleep mode (red keyboard leds with 'heart-beat' effect).
Once keyboard is in "disabled status" even from BIOS keyboard is not available and leds are off: only mousepad+power button do work (keyboard leds off and keyboard not available from Device Manager if I login into Windows with on-screen keyboard + mouse).





Already restored Aura Core from MS Store + old Aura Core Component 1.0.14 + good old Aura Lighting Service 1.00.41, or latest Aura Service driver (3.03.38) from official download page, and refreshed ASUS ATK drivers, but didn't solve the issue with dead keyboard on resume after Shutdown and Hibernation.
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

davemon50
Level 11
I'm curious if you've started messing with W10 power settings yet. They are way too aggressive and intrusive. I use my own customized power plans on all machines.
Davemon50

hexaae
Level 12
No, nothing strange in power settings and never changed them since a long time ago...
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse

hexaae
Level 12
Help...
--
ASUS ROG Strix GL703GS, GTX 1070 8GB, 32GB RAM, 1920x1080 144Hz G-Sync laptop screen, external monitor UWQHD 3440x1440 Mi Monitor, NVMe 4x, Hori Fighting Stick Mini, XBox One BT controller, ROG Strix Carry mouse