cancel
Showing results for 
Search instead for 
Did you mean: 

GL702VM not booting after windows update updated the bios

AFRIKA
Level 7
Hello,

this morning windows prompted me to install updates, i didn't check what updates where and i clicked restart, the computer shutted down, and restarted doing a BIOS update, i noticed that it showed a version dated around april 2019, but when i checked the last bios for this model on the asus page only shows bios dated 2017 as the last one, anyway the update process finalized the bios update, and after another reboot the laptop is stuck in the ROG logo.

i tried to enter to the bios set up but it doesn’t, i just can turn it on or off, I think windows update flashed my laptop with a wrong bios version.

what can i do? is there a way to reflash de bios with the correct one?

Thanks for the help.
56,866 Views
34 REPLIES 34

eklembacak
Level 7
...

eklembacak wrote:


yes, im having exactly that problem, everythime i put an ssd in the sata or NVME port it just get stucked. i have now a 1300USD brick thanks to windows update, ASUS, we need a newer bios fixing this ASAP. this is ridiculous.

....

and next for dont bios update on microsoft ; in the search box> sysdm.cpl, select> hardware > device installation settings > select no ...

AFRIKA
Level 7
thanks! i chatted with asus support and they provided me with the same instructions for the downgrade, except that i downgraded directly to the 3.06, so far windows hasnt downloaded again the bios. thanks for this instructions!

Bios 311 through winupdate worked fine on my GL702VS (says GL702VSK in msinfo32) but now i see Asus has put up bios 310 not 311 for download where only 307 was available before so maybe 311 is broken at least for some GL702Vxx versions. Other than that i don't think Microsoft makes the bios Asus does but Asus tried deploying them through windows update.

Last windows updated new bios 307 through system firmware under device manager. But in asus official website only 305 version is the latest.

I am sure microsoft will never produces bios for non microsoft surface devices.,, so the respective OEM has produced and uploaded their bios files to the windows update database server . Hence while updating windows updates to devices , windows try to install new bios after detecting compatible bios to the oem devices.

I am using R542UQ-DM153 , currently with x542UQ.307 bios . without single problems. I always update bios from microsoft windows updates
Intel i5 7200U_ Nvidia 940MX _Windows_11_Enterprise_64bit_22H2_buildno_22621.754

AFRIKA
Level 7
well.. the bios 310 that windows update is pushing for the GL702VM is bugged, doesnt boot SSDs... so we have to go back to the 306.

asus published official bios 3.10 for gl702vm .

first microsoft upgrade 3.10 bios . but asus not publish yet . after that i downgrade bios 3.06 . because ssd problem .

this time ssd ok but sometimes when open pc , stuck black screen problem with old bios 3.06 3.05 all of them i tried .

i guess 1809 new update have problem with old bios version .

so i download bios 3.10 on asus official today and update again . black screen gone . ssd ok .

but this time , fan on fire 😄 a complete circus progress .

i hope so after that we dont see any bug on 3.10 .... in test ...

i am tired about asus .