cancel
Showing results for 
Search instead for 
Did you mean: 

GL553V won't boot, no POST just lights

ultimazlitezjc
Level 7
Need help on my GL553V laptop please.

Suddenly won't boot, just showing lights on its keyboard
I don't know if its an error code, tried googling it but no avail.
Have tried resitting memory on different slot also.

https://youtu.be/3Dzrgxamhe0

Anyone did have the same issue?
5,730 Views
14 REPLIES 14

Tor_Spo
Level 8
ultimazlitezjc wrote:
Need help on my GL553V laptop please.

Suddenly won't boot, just showing lights on its keyboard
I don't know if its an error code, tried googling it but no avail.
Have tried resitting memory on different slot also.

https://youtu.be/3Dzrgxamhe0

Anyone did have the same issue?


sometimes the cable of the integrated monitor loses connection.
so to isolate that out, please try with external monitor and see if it goes to operating system.

you can also try to hold power button down for 30-45seconds then it uses failsafe values for the bios.

Tor_Spo wrote:
sometimes the cable of the integrated monitor loses connection.
so to isolate that out, please try with external monitor and see if it goes to operating system.

you can also try to hold power button down for 30-45seconds then it uses failsafe values for the bios.


Hi, thank you for your reply.
I've tried both of them but still won't boot and doesn't show anything on a second monitor using HDMI

FULLMETALJACKET7 wrote:
Press FN+F8, see if anything happens.


Hello, thank you.
nothing happens on it also

this video now shows another behavior when I left it plugged in https://youtu.be/Dpgs3W61WvM

FULLMETALJACKET
Level 11
Press FN+F8, see if anything happens.

FULLMETALJACKET
Level 11
Unplug the battery and try again.

FULLMETALJACKET7 wrote:
Unplug the battery and try again.


Hi, Still the same issue even unplugging the battery inside.
I am thinking that this might be a motherboard issue

(also out of warranty)

ultimazlitezjc wrote:
Hi, Still the same issue even unplugging the battery inside.
I am thinking that this might be a motherboard issue

(also out of warranty)


Might be.
Remove everything that is installed and try again. Leave nothing but the essential for it to power on. Only one ram stick and the battery should be enough.

FULLMETALJACKET7 wrote:
Might be.
Remove everything that is installed and try again. Leave nothing but the essential for it to power on. Only one ram stick and the battery should be enough.


still the same issue 😞

ultimazlitezjc wrote:
still the same issue 😞


did you check is the lcd cable properly inserted in to its "slot"

Tor_Spo wrote:
did you check is the lcd cable properly inserted in to its "slot"


Yes, checked it and still the same.

Is there any beep codes or lighting codes for this laptop model 😞