cancel
Showing results for 
Search instead for 
Did you mean: 

GL504GM huge framedrops - GPU usage spiking out of nowhere

cedie1994
Level 7
I've seen multiple people mentioning the extact issue as i'm encountering myself.

So about a week ago, i started recieving these crazy "stutters", that make any somewhat GPU intensive game completely unplayable.
The GPU usage would randomly spike from 60 - 70% to 99 - 100% resulting in my clock speed to drop significantly and my FPS to hit single digits.

This has nothing to do with the ingame settings, all of the games i encountered this issue with used to run perfectly fine and at very reasonable temperatures.

The issue is demonstrated in the video shown below:
https://www.youtube.com/watch?v=ZPJ_BNjk8yY&feature=youtu.be

I've pretty much exhausted all the solutions i could find on this forum, and so far nothing has worked.
The sudden nature of this issue appearing has made me think it's caused by some recent (driver)update, but i can't be sure.
5,777 Views
13 REPLIES 13

rohmuk3333
Level 7
cedie1994 wrote:
I've seen multiple people mentioning the extact issue as i'm encountering myself.

So about a week ago, i started recieving these crazy "stutters", that make any somewhat GPU intensive game completely unplayable.
The GPU usage would randomly spike from 60 - 70% to 99 - 100% resulting in my clock speed to drop significantly and my FPS to hit single digits.

This has nothing to do with the ingame settings, all of the games i encountered this issue with used to run perfectly fine and at very reasonable temperatures.

The issue is demonstrated in the video shown below:
https://www.youtube.com/watch?v=ZPJ_BNjk8yY&feature=youtu.be

I've pretty much exhausted all the solutions i could find on this forum, and so far nothing has worked.
The sudden nature of this issue appearing has made me think it's caused by some recent (driver)update, but i can't be sure.



I had the same laptop and same issue , add another 16gb ram ,it has drastically improved my performance ,hope it works for you too.

aayushpal
Level 7
cedie1994 wrote:
I've seen multiple people mentioning the extact issue as i'm encountering myself.

So about a week ago, i started recieving these crazy "stutters", that make any somewhat GPU intensive game completely unplayable.
The GPU usage would randomly spike from 60 - 70% to 99 - 100% resulting in my clock speed to drop significantly and my FPS to hit single digits.

This has nothing to do with the ingame settings, all of the games i encountered this issue with used to run perfectly fine and at very reasonable temperatures.

The issue is demonstrated in the video shown below:
https://www.youtube.com/watch?v=ZPJ_BNjk8yY&feature=youtu.be

I've pretty much exhausted all the solutions i could find on this forum, and so far nothing has worked.
The sudden nature of this issue appearing has made me think it's caused by some recent (driver)update, but i can't be sure.

I've been suffering from this for almost 2 years now. no help from asus. they have replace my mother board twice. the issue is with bios. the only stable bios is 307. I asked them to install bios 307 on the second replacement of mother board. everything starte working just fine foe about 4 months but then one day microsoft forced an update I don't know how but I'm back to square 1. only way to resolve this issue is throw away this machine or install bios 307. do not depend on ASUS for this..i have complained about this about 17 times. my warranty will run out November 2021. i had 3 years of warranty. and I've tried 17 times till now. no help from asus. we just had a bad luck choosing bad company.

aayushpal wrote:
I've been suffering from this for almost 2 years now. no help from asus. they have replace my mother board twice. the issue is with bios. the only stable bios is 307. I asked them to install bios 307 on the second replacement of mother board. everything starte working just fine foe about 4 months but then one day microsoft forced an update I don't know how but I'm back to square 1. only way to resolve this issue is throw away this machine or install bios 307. do not depend on ASUS for this..i have complained about this about 17 times. my warranty will run out November 2021. i had 3 years of warranty. and I've tried 17 times till now. no help from asus. we just had a bad luck choosing bad company.


Anyone have copy of bios 307?

xarot
Level 11
I managed to find BIOS 307 via quick googling today. I don't remember having this issue when I bought the laptop but with recent BIOSes it was basically useless for any gaming with frame drops constantly to like 3 fps. I have tested Cyberpunk 2077 with same save and the BIOS 307 don't seem to have any frame drops. If this is a BIOS issue it is actually good thing because then there is most likely no hardware issue.

I've been thinking it could be something with the cooling or CPU/GPU performance settings causing throttling and GPU usage probably hits 100 % when the clocks actually decrease due to throttling when the issue occurs.

Anyway, now I have tried to disable the Firmware in Device Manager and prevented Windows from downloading hardware drivers from Windows update, I hope it is enough. I flashed the 307 BIOS via FAT32 formatted disk using CTRL+HOME pressed when powering up until I could select the BIOS I wanted to flash.

I actually like the looks and performance of this laptop when it works. I hope it does now.

EDIT. Cyberpunk worked fine but got same issue with Metro Exodus too, however that occurred soon after I changed from Balanced to Overboost cooling mode. Does it mess up the cooling? When switching back to balanced, it seemed to work stable at least 10 minutes until I quit.
Main: i9-10980XE - Rampage VI Extreme Encore - 64 GB G.Skill Trident Z Royal 3600 CL16 - Strix RTX 3090 - Phanteks Enthoo Primo - Corsair AX1500i - Samsung 960 PRO 1 TB + Intel 600P 1TB - Water cooling
HTPC: i7-6950X - X99-M WS - 32 GB G.Skill RipjawsV DDR4-2400 - GTX1050TI - Bitfenix Pandora - Corsair AX860 - Intel 750 400 GB + Samsung 1 TB 850 EVO
All around: i9-7980XE - Rampage VI Extreme - 64 GB G.Skill 4000 CL18-19-19-39 - Strix RTX3090 - Phanteks P500A - Samsung 960 EVO 512 GB - Water cooling