cancel
Showing results for 
Search instead for 
Did you mean: 

GL503VM-DB74 Keyboard (and kb backlight) not working in OS and BIOS

dictorclef
Level 7
Hi, I had posted a reply to this post, https://rog.asus.com/forum/showthread.php?104550-Asus-ROG-Strix-GL503GE-laptop-keyboard-is-not-worki... , but since it's a old thread I guess it hasn't got much attention. Basically, my problem is exactly the same as the one detailed by the above post's original creator. The keyboard suddenly stopped working and the backlight, including the power button's backlight is no longer working. (the power button itself is working, so I can still turn the laptop on) Also, like mentionned in that thread, the power status light stays on even when the laptop is turned off. I've done most of the troubleshooting steps that the other user did (such as using Ubuntu to exclude any OS-specific issue), to no avail. The hotfix seems to be my only hope (before RMA), but the updater fails, saying something like "could not find update in the updater's folder", which doesn't seem connected to the keyboards problem. (Maybe it refuses to do the update because my laptop is of another model, despite the chassis and keyboard being identical?). Any help would be appreciated. Thanks.
2,284 Views
6 REPLIES 6

jaykhandelwal
Level 7
dictorclef wrote:
Hi, I had posted a reply to this post, https://rog.asus.com/forum/showthread.php?104550-Asus-ROG-Strix-GL503GE-laptop-keyboard-is-not-worki... , but since it's a old thread I guess it hasn't got much attention. Basically, my problem is exactly the same as the one detailed by the above post's original creator. The keyboard suddenly stopped working and the backlight, including the power button's backlight is no longer working. (the power button itself is working, so I can still turn the laptop on) Also, like mentionned in that thread, the power status light stays on even when the laptop is turned off. I've done most of the troubleshooting steps that the other user did (such as using Ubuntu to exclude any OS-specific issue), to no avail. The hotfix seems to be my only hope (before RMA), but the updater fails, saying something like "could not find update in the updater's folder", which doesn't seem connected to the keyboards problem. (Maybe it refuses to do the update because my laptop is of another model, despite the chassis and keyboard being identical?). Any help would be appreciated. Thanks.


Hey! any update to your problem! I am facing the same thing with my GL703VM, keyboard is not working (even in BIOS) and even after shutdown the power led light stays turned on, I've to press and hold power key for 5-10secs to turn that light off. I did submit my device to ASUS service center and they said that they've ordered a new keyboard to check if that works, but I dont think this is gonna solve the issue, as on the thread you mentioned the issue got solved with a hotfix, means this most probably is not a hardware malfunction.

This sounds more like an NKRO (N-KEY ROLLOVER ) firmware issue rather than hardware.

i think there is a fix for this on the support page for this model on their website literally titled KB hotfix , auto run it and it should just scan the USB device and implement the .bin file with the relevant firmware and bring the KB back to life.

If it fails to find the USB device within the FW updater, then chances are its an EEPROM issue or a board issue rather than the Keyboard.
If thats the case then it'll require an RMA if it cant update the n-key fw using the updater within the hotfix download.

I am not able to find any KB Hotfix for both of these models, there is some MEUpdate Hotfix indeed but I dont think these are related!

jaykhandelwal wrote:
I am not able to find any KB Hotfix for both of these models, there is some MEUpdate Hotfix indeed but I dont think these are related!


your issue doesnt look like its NKRO related after reading your initial post, if it was, your Keyboard power LED wouldnt be functional.

Your issue is likely hardware related. With the symtoms youve described it could be various things.
either
A. the keyboard is faulty and whatever is being sent from the ribbon to MB is wrong and its persistently in an on/off cycle due to KB error.
B. There is a mainboard error thats likely eeprom related and its incorrectly reading the information given to it by your KB input.
c. and least likely, a contact short between KB and MB causing erratic behaviour, which is uncommon but can happen on the 703 models as people have complained about this.

Id leave the service center to find the cause, but itll likely be a replacement MB or KB.

karl_frascari
Level 8
Hey guys, did you find solutions for this problem? My keyboard is not working at all!

I have the same problem with my rog gl502vmk
but lighting works for me, I downloaded asus aura software and the lights work, but the keyboard still doesn't respond