cancel
Showing results for 
Search instead for 
Did you mean: 

GL503GE - fan running at max speed driving me crazy!

warmbooter
Level 7
Starting some weeks ago, the fan speed of the laptop (GL503GE) goes to maximum speed with no apparent reason! It stays like this for ~30 minutes after booting Windows, and gets back to normal behavior. CPU usage is low, temperatures are all around ~40C.

As always, ASUS support was worthless. They asked me to send the laptop to RMA, but I'm in Brazil and the warranty doesn't work here. I'm 99% sure this is a BIOS/software/driver problem. I read several other posts on this forum with people having the same problem, but seems that nobody was able to really find a fix for it.

Any hint?

PS: BIOS is 313 (the last one), all drivers are up to date. ROG Gaming Center shows no information of CPU and Temperature, unless I activate the nVidia card before opening it. Trying to change the fan profile to "silent" doesn't work, since it always get back to "balance". Gaming Center looks like a pretty useless app to me.

Carlos
16,622 Views
5 REPLIES 5

Super_Gnome
Level 11
warmbooter wrote:
nobody was able to really find a fix for it.

Any hint?


I have had a similar problem with a machine with an Asus motherboard. The motherboard is a Rampage III Black Edition. When I installed Windows 10 I could no longer install Asus software like AI Suite II. AI Suite II had an easy way to adjust fan speeds. I later installed a Ryuo CPU cooler (an AOI cooler) and an industrial fan, (a Noctua 140mm) in the rig and after starting my machine found this amazing Noctua fan ran beautifully but at a very noisy level. Nothing would slow this fan down either. Hence I was stumped about what to do. After doing numerous searches I learned about and installed SpeedFan, which allowed fan control and this allowed this fan to slow right down. There are youtube videos about it which helped. Very recently though, I've been cutting out any extra software running unnecessarily and wondered if it wasn't possible to adjust fan speed in the BIOS. Well, I then went into the BIOS and was able to slow that fan down. Since then I have uninstalled SpeedFan, and constantly monitor my system using HWMonitor to be sure there are no heat problems.

If I were you and couldn't install any Asus software for fan control, or change the fan settings in the BIOS (which for me was easy) then I would try SpeedFan. You can turn it on and off whenever you like. A second option might be trying MSI Afterburner. I am not certain but think it has fan control options. I have had problems with MSI Afterburner though--namely a related program caused some software/system conflicts. There are also youtube videos on how to use and set up MSI Afterburner and a related program.

In a nutshell, why not try BIOS settings? If that doesn't work maybe SpeedFan is your solution until you figure out the source of the problem.

Hopefully this helps. Good luck.

warmbooter
Level 7
Actually the only software that is supposed able to control the fan speed is Asus gaming center. Speedfan, msi afterburner, etc doesn't work with this notebook. No option in the bios either.

My machine is gl504gm. My machine also has fan failure. I have searched all forums, official forums and Baidu Post Bar, and many other places. The authorities have not given any useful solutions. Finally, I found a useful method in Baidu Post Bar. I don't know if it is useful for everyone. At least he solved my problem.

The solution is to take the back cover of the laptop apart, pull out the battery and fan wiring on the motherboard separately, and then plug them back in.

So the fan is quiet when my computer is turned on. It has been working normally for at least a month.

————translate by baidu.com

棽木 wrote:
My machine is gl504gm. My machine also has fan failure. I have searched all forums, official forums and Baidu Post Bar, and many other places. The authorities have not given any useful solutions. Finally, I found a useful method in Baidu Post Bar. I don't know if it is useful for everyone. At least he solved my problem.

The solution is to take the back cover of the laptop apart, pull out the battery and fan wiring on the motherboard separately, and then plug them back in.

So the fan is quiet when my computer is turned on. It has been working normally for at least a month.

————translate by baidu.com


Thank you so much! After reading your post, I decided to try it out. I opened the laptop, unplugged the battery and the fan cables, blew some air to clean the fans (even when they were not dirty) and plugged everything back.

The problem seems to be gone, at last for the past 2 days, the fans are running normally.

PS: Interesting that there was no signal of bad contact or any problem with the cable connections, so I wonder how this fixed the problem.

棽木 wrote:

The solution is to take the back cover of the laptop apart, pull out the battery and fan wiring on the motherboard separately, and then plug them back in.

So the fan is quiet when my computer is turned on. It has been working normally for at least a month.

————translate by baidu.com


Well, looks like the solution is temporary. After 1 month of *no problem at all*, the fan started to behave like crazy again. I wonder what causes the problem. Looks like I'll have to disconnect the cables every month to keep it quiet.