cancel
Showing results for 
Search instead for 
Did you mean: 

GL503 wont boot into Win10 after BIOS update

dhughes2
Level 7
I received a new GL503VS-DH74 last week. I setup Windows 10 and updated it with all available patches. Device Manager was showing a BIOS update for my machine. It shut down windows, booted into the bios and completed the upgrade (currently on bios version 300). Now it won't boot into Windows 10, it blue screens saying "Inaccessible Boot Device". It seems Windows set the boot partition to boot into the BIOS, but now won't boot anymore. Any suggestions as to how to get Windows to boot again?

I also tried booting to a Windows 10 install USB, but it won't detect the M.2 drive, only the SATA drive. The BIOS still shows the 250Gb M.2 drive as detectable.

ASUS website shows an available BIOS update v304 for the ROG STRIX SCAR editions, but I downloaded it and unzipped it (GL503VD-AS.304), and tried to upgrade the BIOS using the Flash Utility in the BIOS, but it says that the file is not a valid BIOS file.

Any help getting my new machine up and running would be greatly appreciated!
4,236 Views
2 REPLIES 2

thebiggboss180
Level 9
After the bios update ur bios settings well get reset
U have to stop secure boot and enable csm

Fran_ZA
Level 7
i recently updated my bios as well, nothing have been changed on the device, but it only boots into a black screen, no boot logo, no nothing

Asus ROG GL503GE
Windows 10 64