cancel
Showing results for 
Search instead for 
Did you mean: 

GL502VS Battery not detected

Gam3rNa5h
Level 7
I've got a gl502vs and its saying the battery is not detected. Happened once about a week back but was solved after restarting. Today it occurred again. The laptop is not booting without ac power connected, but it does not turn off if I disconnect ac power while the laptop is on, indicating the battery is working. Guessing its a software issue. Uninstalled the two drivers i saw under Battery in device manager, then reinstalled by clicking "scan for new hardware", but it didn't solve the problem. Battery is inside the case and so not detachable. How do I fix this? Ask if you need more info. This is all i could think of at the moment. Thanks.

UPDATE: Fixed it. Removed the case and detached the battery. Then booted on AC power, went to device manager and uninstalled driver under battery. Then shutdown, inserted battery and booted up. The system recognised the battery and now its working fine. I think it might have been a windows update that messed up the drivers. Found the solution in
https://www.tenforums.com/drivers-hardware/63401-no-battery-detected-error-asus-laptop.html
2,742 Views
1 REPLY 1

Gam3rNa5h
Level 7
It occured again and this time i just opened the cover then removed and reinserted the battery pin. Didn't do any of the other steps like unistalling the driver. I thought it might be a loose contact so i put a piece of scotch tape on top to hold it in place. Is it okay to put tape on the pin? What tape should i use which is safe?