cancel
Showing results for 
Search instead for 
Did you mean: 

G75VW Windows 8 Audio Drivers for subwoofer

krazun
Level 7
Hello,

it is really nice that the windows 8 drivers for the G75VW are out now. Everything except the subwoofer is working now.

is a windows 8 version of the audio drivers in development ? and is there any timeframe in which we can expect them?

many thanks,
krazun
356 Views
64 REPLIES 64

povetkin wrote:
6.0.10.1200a


I would advise against downloading thus, unless you, Povetkin, and others, can verify that it works.
G75VW-BBK5 Windows 8 Pro 1TB HDD, 180GB Corsair Force GT Sata3 SSD, 16GB DDR3, GeForce GTX 660M, Intel i-7 3610-QM 2.3Ghz Turboboost to 3.3Ghz

Try the method that I prescribed. Very easy and it works, and has been working. You don't have to go through the entire mess of having others reinstall their OS's. This works, and I wish other people would just try it out and add to the verification that there is a complete solution out there.

finalhour wrote:
I would advise against downloading thus, unless you, Povetkin, and others, can verify that it works.

Perfectly work on windows 8.

Unfortunately, Windows 8 Drivers are still buggy and I think this has to do with compatibility with drivers conflicting each other and how they are installing in Windows 8. I am not sure how upgraded Windows 8 differs from a clean install other than they just copy your User files and settings over.

If you can get Windows 8 to a driver-less state, I think you have a chance of installing VIA driver 10600 without fail. I wasn't able to isolate what drivers were causing the issues since I made sure to install the VIA Audio drivers first before anything else. So far all my attempts to manually install the drivers all failed.

I stumbled across this method when I was trying to connect my arduino with Windows 8 and kept on getting an error for "Missing driver signature". I was getting sick of the guy putting mis-information on the forum and was waiting for an actual complete solution. I was maybe a minute away from getting rid of Windows 8 and going back to Windows 7 just to get my audio working properly. Here is how to do it, either write it down, take notes, or take a picture:


1. Windows Key + R
2. Type the following command in -> shutdown.exe /r /o /f /t 00
3. Click the "OK" button
4. System will restart to a "Choose an option" screen
5. Select "Troubleshoot" from "Choose an option" screen
6. Select "Advanced options" from "Troubleshoot" screen
7. Select "Windows Startup Settings" from "Advanced options" screen
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement" (F7)

Once you restart into Windows 8, you can install the latest Windows 7 Drivers for this.
I attached a screenshot, notice there is full control of the subwoofer and playback is excellent.
14486

Please verify that it is working, and your welcome 🙂

Hi! I did a fresh install of Windows 8 a couple of days ago but couldn't get the bass ("bass"?) working even following your recommendation (thanks, by the way). Did I miss something? I'm attaching a screenshot. The bass doesn't make any sound when clicked. 20238

timechg wrote:
I stumbled across this method when I was trying to connect my arduino with Windows 8 and kept on getting an error for "Missing driver signature". I was getting sick of the guy putting mis-information on the forum and was waiting for an actual complete solution. I was maybe a minute away from getting rid of Windows 8 and going back to Windows 7 just to get my audio working properly. Here is how to do it, either write it down, take notes, or take a picture:


1. Windows Key + R
2. Type the following command in -> shutdown.exe /r /o /f /t 00
3. Click the "OK" button
4. System will restart to a "Choose an option" screen
5. Select "Troubleshoot" from "Choose an option" screen
6. Select "Advanced options" from "Troubleshoot" screen
7. Select "Windows Startup Settings" from "Advanced options" screen
8. Click "Restart" button
9. System will restart to "Advanced Boot Options" screen
10. Select "Disable Driver Signature Enforcement" (F7)

Once you restart into Windows 8, you can install the latest Windows 7 Drivers for this.
I attached a screenshot, notice there is full control of the subwoofer and playback is excellent.
14486

Please verify that it is working, and your welcome 🙂

ansa256 wrote:
Hi! I did a fresh install of Windows 8 a couple of days ago but couldn't get the bass ("bass"?) working even following your recommendation (thanks, by the way). Did I miss something? I'm attaching a screenshot. The bass doesn't make any sound when clicked. 20238



That's Interesting, here is a screenshot of my settings. Maybe you are using the WIndows 8 drivers exclusively? I downloaded the Windows 7 Drivers and installed it using the method that I prescribed:

20987

For anyone having problems installing drivers, here's my own method that worked for me:
(Before starting, make sure to download the latest windows 7 via audio drivers from asus support, even if you are on windows 8, and extract the zip to a new folder wherever you want)

1.) Go to "Device Manager"
2.) Uninstall any current audio drivers that you currently have under "Sound, video and game controllers"
3.) Right click anywhere and choose "Scan for hardware changes"
4.) Once it finds that the audio drivers are missing it will automatically install some audio drivers
5.) Go back to "Sound, video and game controllers"
6.) Right click on the driver it automatically installed (VIA or NVIDIA)
7.) Select "Update Driver Software"
8.) And select "Browse my computer for driver software"
9.) Select browse and find the folder you extracted to and select that
10.) Tick the "Include subfolders" box and click next
11.) When it finishes restart your laptop
12.) Find the folder you extracted the drivers to and run the setup inside of it
13.) Go through all the steps and wait for the setup to finish
14.) Restart your laptop

Now when you go to playback devices from the taskbar you are able to use the 5.1 channel surround and subwoofer, and via hd audio deck will be properly installed and working

Hope this helps! 😉

animator776 wrote:
For anyone having problems installing drivers, here's my own method that worked for me:
(Before starting, make sure to download the latest windows 7 via audio drivers from asus support, even if you are on windows 8, and extract the zip to a new folder wherever you want)

1.) Go to "Device Manager"
2.) Uninstall any current audio drivers that you currently have under "Sound, video and game controllers"
3.) Right click anywhere and choose "Scan for hardware changes"
4.) Once it finds that the audio drivers are missing it will automatically install some audio drivers
5.) Go back to "Sound, video and game controllers"
6.) Right click on the driver it automatically installed (VIA or NVIDIA)
7.) Select "Update Driver Software"
8.) And select "Browse my computer for driver software"
9.) Select browse and find the folder you extracted to and select that
10.) Tick the "Include subfolders" box and click next
11.) When it finishes restart your laptop
12.) Find the folder you extracted the drivers to and run the setup inside of it
13.) Go through all the steps and wait for the setup to finish
14.) Restart your laptop

Now when you go to playback devices from the taskbar you are able to use the 5.1 channel surround and subwoofer, and via hd audio deck will be properly installed and working

Hope this helps! 😉


Absolutely does work!!! Ty amimator for sharing, and Platinum for verifying. Scaling works great. Only downside is that subwoofer is now full range and any EQ settings effect all speakers, a very small price to pay after all the frustrating times of adjusting seperate volumes. Still is a drag that Asus never did really fix this, and we could use the subwoofer only for it's intended frequencies. Been an Asus fan for years in both laptops and motherboards for my gaming pc builds. This mess was disturbing in such a "quality" laptop. 1st time I have been let down by the company.